pkgsrc/graphics/OpenRM/patches/patch-ai
jlam 82908831d8 * Libtoolize graphics/OpenRM so that we correctly build shared libraries
on all platforms supported by libtool.

* Remove the unnecessary dependencies on glut and perl, and only use
  perl as a build dependency.

* Use REPLACE_PERL instead of hand-crafted substitution code.

Bump the PKGREVISION for graphics/OpenRM to 2.  Due to the changed
dependency graph, bump the PKGREVISION for packages that use the OpenRM
libraries.  In this case, games/genecys-client is the only one, so
bump its PKGREVISION to 2.
2005-06-23 04:02:48 +00:00

13 lines
472 B
Text

$NetBSD: patch-ai,v 1.1 2005/06/23 04:02:48 jlam Exp $
--- rm/Makefile.x11.orig 2004-01-16 11:42:38.000000000 -0500
+++ rm/Makefile.x11
@@ -98,7 +98,7 @@ $(LIBDIR)/$(RMLIB): $(OBJECTS)
@if ([ -d $(LIBDIR) ]) then :; else (mkdir $(LIBDIR)); fi
@if (\rm -f $(LIBDIR)/$(RMLIB)) then :; fi
@$(MAKELIB) $(ARCHFLAGS) $(RMLIB) $(MAJOR) $(MINOR) $(OBJECTS)
- @mv $(RMLIB)* $(LIBDIR)
+ @cp $(RMLIB)* $(LIBDIR)
dep:
@makedepend -Y -I../include -I/$(GLINC) *.c -f depend