pkgsrc/math/gsl/patches/patch-ae
wiz 9c7660771f Update gsl to 2.0.
No shlib major bump despite the big version bump.

* What is new in gsl-2.0:

** fixed bug #43258 for hypergeometric functions (Raymond Rogers)

** added L-curve analysis routines for linear Tikhonov regression

** add running statistics module

** added bilinear and bicubic interpolation (David Zaslavsky)

** added function gsl_multifit_robust_residuals to compute robust
   fit residuals

** added Steffen monotonic interpolation method (Jean-François Caron)

** added new nonlinear least squares solver 'lmniel' suitable for
   systems with large numbers of data

** nonlinear least squares solver now tracks the number of function
   and Jacobian evaluations, see example program for details

** the 'fdf' field of gsl_multifit_function_fdf is now deprecated
   and does not need to be specified for nonlinear least squares
   problems

** added extensive test suite to nonlinear least squares module,
   resulting in a few minor bug fixes; the routine
   gsl_multifit_fdfsolver_driver has been rewritten (with API change)
   to handle the various error codes of the lmsder iterate
   routine, resulting in a high level caller which is highly robust
   for a wide class of problems

** added support for sparse matrices, including a GMRES
   iterative linear solver

** added routines gsl_linalg_givens and gsl_linalg_givens_gv
   for Givens rotations

** added Tikhonov (ridge) regularization to least squares module
   (linear and nonlinear)

** removed unused argument 'n' from gsl_sf_ellint_D

** merged bspline_deriv_workspace into bspline_workspace to simplify
   bspline API; the functions
     gsl_bspline_deriv_alloc
     gsl_bspline_deriv_free
   are now deprecated and will be removed in a future release.

** merged ALF extension into GSL for associated Legendre functions;
   api has changed; consequently the functions:
     gsl_sf_legendre_Plm_array
     gsl_sf_legendre_Plm_deriv_array
     gsl_sf_legendre_sphPlm_array
     gsl_sf_legendre_sphPlm_deriv_array
     gsl_sf_legendre_array_size
   are now deprecated and will be removed in a future release.

** added function gsl_multifit_robust_weights to allow user to
   access the various weighting functions
2015-11-06 11:19:48 +00:00

16 lines
424 B
Text

$NetBSD: patch-ae,v 1.5 2015/11/06 11:19:48 wiz Exp $
Tags: for-upstream
siman_tsp.c uses many functions from libm.
--- siman/Makefile.am.orig 2015-10-15 18:09:20.000000000 +0000
+++ siman/Makefile.am
@@ -16,6 +16,7 @@ siman_tsp_LDADD = libgslsiman.la ../rng/
CLEANFILES = siman_test.out
libgslsiman_la_SOURCES = siman.c
+libgslsiman_la_LIBADD = -lm
pkginclude_HEADERS = gsl_siman.h
AM_CPPFLAGS = -I$(top_srcdir)