pkgsrc/math/superlu/patches/patch-aa
jperkin d90e2f5f4d Remove mk/find-prefix.mk usage from the math category.
The find-prefix infrastructure was required in a pkgviews world where
packages installed from pkgsrc could have different installation
prefixes, and this was a way for a dependency prefix to be determined.

Now that pkgviews has been removed there is no longer any need for the
overhead of this infrastructure.  Instead we use BUILDLINK_PREFIX.pkg
for dependencies pulled in via buildlink, or LOCALBASE/PREFIX where the
dependency is coming from pkgsrc.

Provides a reasonable performance win due to the reduction of `pkg_info
-qp` calls, some of which were redundant anyway as they were duplicating
the same information provided by BUILDLINK_PREFIX.pkg.
2015-11-25 12:51:41 +00:00

54 lines
1.3 KiB
Text

$NetBSD: patch-aa,v 1.4 2015/11/25 12:51:42 jperkin Exp $
--- make.inc.orig 2004-02-05 20:01:19.000000000 +0100
+++ make.inc
@@ -16,29 +16,30 @@
#
# The machine (platform) identifier to append to the library names
#
-PLAT = _solaris
+PLAT =
#
# The name of the libraries to be created/linked to
#
-TMGLIB = tmglib$(PLAT).a
-SUPERLULIB = superlu$(PLAT).a
-BLASLIB = ../blas$(PLAT).a
+TMGLIB = tmglib.a
+SUPERLULIB = libsuperlu.a
+BLASDEF = -DUSE_VENDOR_BLAS
+BLASLIB = -L${LOCALBASE}/lib -lblas
#
# The archiver and the flag(s) to use when building archive (library)
# If your system has no ranlib, set RANLIB = echo.
#
-ARCH = ar
-ARCHFLAGS = cr
-RANLIB = ranlib
+ARCH = ${AR}
+ARCHFLAGS = cru
+#RANLIB = ranlib
-CC = cc
-CFLAGS = -xO3 -xcg92
-FORTRAN = f77
-FFLAGS = -O
-LOADER = cc
-LOADOPTS = -xO3
+#CC = cc
+#CFLAGS = -xO3 -xcg92
+FORTRAN = ${FC}
+#FFLAGS = -O
+LOADER = ${CC}
+LOADOPTS = ${LDFLAGS}
#
# C preprocessor defs for compilation (-DNoChange, -DAdd_, or -DUpCase)
@@ -47,4 +48,4 @@ CDEFS = -DAdd_
#
# The directory in which Matlab is installed
#
-MATLAB = /usr/sww/matlab
+# MATLAB = /usr/sww/matlab