7c73d57863
* Successor of devel/xulrunner, xulrunner-10.0.2. * This is ESR (Extended Support Release) version. * Fix security bugs
107 lines
4.7 KiB
Text
107 lines
4.7 KiB
Text
$NetBSD: patch-aa,v 1.1.1.1 2012/03/15 08:58:28 ryoon Exp $
|
|
|
|
--- configure.in.orig 2012-03-09 22:20:09.000000000 +0000
|
|
+++ configure.in
|
|
@@ -2328,7 +2328,7 @@ case "$target" in
|
|
MOZ_FIX_LINK_PATHS='-Wl,-executable_path,$(LIBXUL_DIST)/bin'
|
|
;;
|
|
|
|
-*-freebsd*)
|
|
+*-freebsd* | *-dragonfly*)
|
|
if test `test -x /usr/bin/objformat && /usr/bin/objformat || echo elf` != "elf"; then
|
|
DLL_SUFFIX=".so.1.0"
|
|
DSO_LDOPTS="-shared"
|
|
@@ -2336,6 +2336,9 @@ case "$target" in
|
|
if test ! "$GNU_CC"; then
|
|
DSO_LDOPTS="-Bshareable $DSO_LDOPTS"
|
|
fi
|
|
+ if test "$LIBRUNPATH"; then
|
|
+ DSO_LDOPTS="-Wl,-R$LIBRUNPATH $DSO_LDOPTS"
|
|
+ fi
|
|
;;
|
|
|
|
ia64*-hpux*)
|
|
@@ -3377,6 +3380,9 @@ dnl ====================================
|
|
case $target in
|
|
*-hpux11.*)
|
|
;;
|
|
+*-dragonfly*)
|
|
+ AC_CHECK_LIB(c, gethostbyname_r)
|
|
+ ;;
|
|
*)
|
|
AC_CHECK_LIB(c_r, gethostbyname_r)
|
|
;;
|
|
@@ -4330,6 +4336,14 @@ if test -n "$YASM"; then
|
|
_YASM_BUILD=` echo ${YASM_VERSION} | $AWK -F\. '{ print $4 }'`
|
|
fi
|
|
|
|
+if test -n "${LIBXUL_SDK_DIR}"; then
|
|
+ AC_MSG_WARN([pkgsrc: LIBXUL_SDK_DIR is set; assuming we want nss and nspr from xulrunner.])
|
|
+ NSPR_CFLAGS="-I${prefix}/include/xulrunner10/unstable `pkg-config --cflags mozilla-nspr`"
|
|
+ NSPR_LIBS="`pkg-config --libs mozilla-nspr`"
|
|
+ NSS_CFLAGS="`pkg-config --cflags mozilla-nss`"
|
|
+ NSS_LIBS="`pkg-config --libs mozilla-nss`"
|
|
+fi
|
|
+
|
|
if test -z "$SKIP_LIBRARY_CHECKS"; then
|
|
dnl system JPEG support
|
|
dnl ========================================================
|
|
@@ -5616,20 +5630,20 @@ if test -n "$MOZ_WEBM"; then
|
|
[MOZ_NATIVE_LIBVPX_DEC_TEST=1],
|
|
([--with-system-libvpx requested but symbol vpx_codec_dec_init_ver not found]))
|
|
if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
|
|
- AC_MSG_CHECKING([for libvpx version >= v0.9.7])
|
|
- dnl We need at least v0.9.7 to fix several crash bugs (for which we
|
|
- dnl had local patches prior to v0.9.7).
|
|
+ AC_MSG_CHECKING([for libvpx version >= v1.0.0])
|
|
+ dnl We need at least v1.0.0 to fix several crash bugs (for which we
|
|
+ dnl had local patches prior to v1.0.0).
|
|
dnl
|
|
dnl This is a terrible test for the library version, but we don't
|
|
dnl have a good one. There is no version number in a public header,
|
|
dnl and testing the headers still doesn't guarantee we link against
|
|
dnl the right version. While we could call vpx_codec_version() at
|
|
dnl run-time, that would break cross-compiling. There are no
|
|
- dnl additional exported symbols between the v0.9.7 release and the
|
|
- dnl v0.9.6 one to check for.
|
|
+ dnl additional exported decoder symbols between the v1.0.0 release
|
|
+ dnl and the v0.9.7 one to check for.
|
|
AC_TRY_COMPILE([
|
|
#include <vpx/vpx_decoder.h>
|
|
- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
|
|
+ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
|
|
#error "test failed."
|
|
#endif
|
|
],
|
|
@@ -5639,7 +5653,7 @@ if test -n "$MOZ_WEBM"; then
|
|
MOZ_LIBVPX_INCLUDES="-I${LIBVPX_DIR}/include"
|
|
MOZ_LIBVPX_LIBS="-L${LIBVPX_DIR}/lib -lvpx"],
|
|
[AC_MSG_RESULT([no])
|
|
- AC_MSG_ERROR([--with-system-libvpx requested but it is not v0.9.7 or later])])
|
|
+ AC_MSG_ERROR([--with-system-libvpx requested but it is not v1.0.0 or later])])
|
|
fi
|
|
CFLAGS=$_SAVE_CFLAGS
|
|
LDFLAGS=$_SAVE_LDFLAGS
|
|
@@ -5673,11 +5687,11 @@ if test -n "$MOZ_WEBM" -a -z "$MOZ_NATIV
|
|
|
|
dnl See if we have assembly on this platform.
|
|
case "$OS_ARCH:$CPU_ARCH" in
|
|
- Linux:x86)
|
|
+ Linux:x86|DragonFly:x86|*BSD:i386)
|
|
VPX_ASFLAGS="-f elf32 -rnasm -pnasm"
|
|
VPX_X86_ASM=1
|
|
;;
|
|
- Linux:x86_64)
|
|
+ Linux:x86_64|DragonFly:x86_64|*BSD:x86_64)
|
|
VPX_ASFLAGS="-f elf64 -rnasm -pnasm -DPIC"
|
|
VPX_X86_ASM=1
|
|
;;
|
|
@@ -8915,6 +8929,8 @@ if test -z "$MOZ_NATIVE_NSPR"; then
|
|
AC_MSG_WARN([Recreating autoconf.mk with updated nspr-config output])
|
|
if test "$OS_ARCH" != "WINNT"; then
|
|
NSPR_LIBS=`./nsprpub/config/nspr-config --prefix=$LIBXUL_DIST --exec-prefix=$MOZ_BUILD_ROOT/dist --libdir=$LIBXUL_DIST/lib --libs`
|
|
+ AC_MSG_WARN([pkgsrc: adding run path to NSPR_LIBS for bundled NSPR.])
|
|
+ NSPR_LIBS="-Wl,-R${prefix}/lib/\${MOZILLA_PKG_NAME} ${NSPR_LIBS}"
|
|
$PERL -pi.bak -e "s '^NSPR_LIBS\\s*=.*'NSPR_LIBS = $NSPR_LIBS'" config/autoconf.mk
|
|
NSPR_CFLAGS=`./nsprpub/config/nspr-config --prefix=$LIBXUL_DIST --exec-prefix=$MOZ_BUILD_ROOT/dist --includedir=$LIBXUL_DIST/include/nspr --cflags`
|
|
$PERL -pi.bak -e "s '^NSPR_CFLAGS\\s*=.*'NSPR_CFLAGS = $NSPR_CFLAGS'" config/autoconf.mk
|