* Fix 3581 Ftools: union tool leave holes in output * Fix 4500 Simplify tool freezes QGIS * Fix 4466 Fixes for 'v.what.vect' and 'v.generalize' modules in the GRASS plugin * Fix 4552 Patch for v.what.vect * Fix 4035 Print Composer shape combo box not refecting current shape * Partial Fix 3097 Add preference to set/override environment variables * Fix 2749 Move 'Add to Attributes List' button * Fix 4560 Wrong scale displayed in Map canvas * Partial Fix 4383 Ftools: Improve how processes are handled * Fix 3577 Adding a print composer doesn't dirty the document * Fix 3170 Many GDAL Tools don't work in OS X standalone * Fix 3723 Transparency settings are not applied from *.qml * Fix 3576 qml not read automagically for rasters * Fix 2977 Messy uninstallation of the standalone installer * Union and Symetrical difference works only on whole layer fixed * Save some time in node tool for geometry export and avoid detachs * Initialize default symbol to 0 in rule based renderer * Make relative paths default * Fix tab restoration in project properties * Add helpful info to GdalTools Settings dialog on how to configure GDAL path * New vector layer dialog - show CRS as authid-description pair instead of proj4 string * Fix crash with relative file paths if projPath is not yet defined * Add helpful info to GdalTools Settings dialog on how to configure GDAL path * And a lot of other smaller Bugfixes
28 lines
1.5 KiB
Text
28 lines
1.5 KiB
Text
$NetBSD: patch-src_helpviewer_CMakeLists.txt,v 1.1 2012/01/23 08:58:00 adam Exp $
|
|
|
|
Avoid application bundle on Mac OS X.
|
|
|
|
--- src/helpviewer/CMakeLists.txt.orig 2011-12-10 18:23:35.000000000 +0000
|
|
+++ src/helpviewer/CMakeLists.txt
|
|
@@ -54,7 +54,7 @@ QT4_WRAP_CPP (HELP_MOC_SRCS ${HELP_MOC_
|
|
|
|
#QT4_ADD_RESOURCES(HELP_RCC_SRCS ${HELP_RCCS})
|
|
|
|
-ADD_EXECUTABLE (qgis_help MACOSX_BUNDLE ${HELP_SRCS} ${HELP_MOC_SRCS} ${HELP_UIS_H})
|
|
+ADD_EXECUTABLE (qgis_help ${HELP_SRCS} ${HELP_MOC_SRCS} ${HELP_UIS_H})
|
|
|
|
INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}
|
|
${CMAKE_CURRENT_SOURCE_DIR}/../core
|
|
@@ -97,11 +97,4 @@ SET_TARGET_PROPERTIES(qgis_help PROPERTI
|
|
########################################################
|
|
# Install
|
|
|
|
-IF (APPLE)
|
|
- INSTALL (TARGETS qgis_help BUNDLE DESTINATION ${QGIS_BIN_DIR})
|
|
- # needed because global install_name prefix is for main qgis app
|
|
- INSTALL (CODE "EXECUTE_PROCESS(COMMAND install_name_tool -change ${CMAKE_INSTALL_NAME_DIR}/libqgis_core.${COMPLETE_VERSION}.dylib @executable_path/../../../../lib/libqgis_core.${COMPLETE_VERSION}.dylib \"$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${QGIS_BIN_DIR}/qgis_help.app/Contents/MacOS/qgis_help\")")
|
|
- INSTALL (CODE "EXECUTE_PROCESS (COMMAND ln -sfh ../../../${QGIS_FW_SUBDIR} \"$ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/${QGIS_BIN_DIR}/qgis_help.app/Contents/Frameworks\")")
|
|
-ELSE (APPLE)
|
|
- INSTALL (TARGETS qgis_help RUNTIME DESTINATION ${QGIS_LIBEXEC_DIR})
|
|
-ENDIF (APPLE)
|
|
+INSTALL (TARGETS qgis_help RUNTIME DESTINATION ${QGIS_LIBEXEC_DIR})
|