in NetBSD's src/gnu/libexec/uucp directory. Changes include: * Teaching cu(1) about hardware flow control. * Make cu(1) honor "echocheck" and "binary mode" with respect to inspecting the data stream for newlines. * Make some proper integer casts so as not to break on LP64 platforms. * Teach uucp to substitute for \H with the IP address of the system. * Avoid potential divide-by-zero errors when computing times using serial rates. * Properly initialize some variables. The main difference between this version and the one in NetBSD is the location of uucico, uuconv, and uuxqt -- the vanilla UUCP location is ${PREFIX}/sbin while the NetBSD location is /usr/libexec/uucp. Bump PKGREVISION to 1.
13 lines
487 B
Text
13 lines
487 B
Text
$NetBSD: patch-aa,v 1.2 2006/10/30 03:33:59 jlam Exp $
|
|
|
|
--- unix/Makefile.in.orig 2003-05-29 21:31:50.000000000 -0400
|
|
+++ unix/Makefile.in
|
|
@@ -111,7 +111,7 @@ CONFIG_CLEAN_FILES =
|
|
LIBRARIES = $(noinst_LIBRARIES)
|
|
|
|
libunix_a_AR = $(AR) cru
|
|
-libunix_a_DEPENDENCIES =
|
|
+libunix_a_DEPENDENCIES = $(UNIXOBJS)
|
|
am_libunix_a_OBJECTS = access.$(OBJEXT) addbas.$(OBJEXT) app3.$(OBJEXT) \
|
|
app4.$(OBJEXT) basnam.$(OBJEXT) bytfre.$(OBJEXT) \
|
|
corrup.$(OBJEXT) chmod.$(OBJEXT) cohtty.$(OBJEXT) \
|