pkgsrc/misc/rpm/patches/patch-configure.ac
adam b3fba444d0 RPM 4.13.0.1
Security fixes
* Fix several out of bounds reads in the OpenPGP parser
* Fix handling of OpenPGP reserved tag (should be rejected)
* Fix various crashes from malformed packages with invalid tags

General bugfixes
* Fix %transfiletriggerpostun nondeterministic behavior
* Fix rpmdb cleanup on signal (regression introduced in 4.13.0)

Package building
* Fix debuginfo GDB index generation (regression introduced in 4.13.0)
* Fix malformed packages being generated around 4GB size boundary (regression introduced in 4.12.0)
* Fix special %doc/%license directory inheriting default file permissions (regression introduced in 4.13.0)

Build process
* Fix API documentation generation with Doxygen >= 1.8.8
2017-04-23 08:18:14 +00:00

35 lines
921 B
Text

$NetBSD: patch-configure.ac,v 1.4 2017/04/23 08:18:15 adam Exp $
Avoid -fstack-protector, it is not portable.
Redefine MYPATH to avoid build directory references.
Detect dirfd() and setprogname() functions.
--- configure.ac.orig 2016-11-02 08:42:29.000000000 +0000
+++ configure.ac
@@ -37,7 +37,7 @@ fi
AS=${AS-as}
AC_SUBST(AS)
if test "$GCC" = yes; then
- cflags_to_try="-fno-strict-aliasing -fstack-protector -Wempty-body"
+ cflags_to_try="-fno-strict-aliasing -Wempty-body"
AC_MSG_CHECKING([supported compiler flags])
old_cflags=$CFLAGS
echo
@@ -84,7 +84,7 @@ dnl
if test "$cross_compiling" = "yes"; then
MYPATH=":"
else
- MYPATH=$PATH
+ MYPATH=$MYPATH
fi
dnl
@@ -547,6 +547,8 @@ AC_CHECK_FUNCS(fdatasync)
AC_CHECK_FUNCS(lutimes)
AC_CHECK_FUNCS(mergesort)
AC_CHECK_FUNCS(getauxval)
+AC_CHECK_FUNCS(dirfd)
+AC_CHECK_FUNCS(setprogname)
AC_REPLACE_FUNCS(stpcpy stpncpy)