* gpglib/configure.in: Use "gpg2" if "gpg" is not found. * sqwebmail.spec.in: Use gnugp2 as a requirement if gnupg is not installed. Replace vixie-cron with cronie as a listed req.
32 lines
1.5 KiB
Text
32 lines
1.5 KiB
Text
$NetBSD: patch-ad,v 1.12 2010/11/10 10:52:47 adam Exp $
|
|
|
|
--- sqwebmail/Makefile.in.orig 2010-11-07 18:42:06.000000000 +0000
|
|
+++ sqwebmail/Makefile.in
|
|
@@ -1144,7 +1144,7 @@ install-perms-local: install-perms-cache
|
|
|
|
htmllibdir.h: config.status
|
|
echo '#define HTMLLIBDIR "@htmldir@"' >htmllibdir.h
|
|
- echo '#define SENDITSH "$(scriptdir)/sendit.sh"' >>htmllibdir.h
|
|
+ echo '#define SENDITSH "$(sysconfdir)/sendit.sh"' >>htmllibdir.h
|
|
echo '#define CALENDARMODE "$(sysconfdir)/calendarmode"' >>htmllibdir.h
|
|
echo '#define LOGINDOMAINLIST "$(sysconfdir)/logindomainlist"' >>htmllibdir.h
|
|
echo '#define MAXMSGSIZE @MAXMSGSIZE@' >>htmllibdir.h
|
|
@@ -1152,7 +1152,7 @@ htmllibdir.h: config.status
|
|
echo '#define SOCKDIR "$(localstatedir)"' >>htmllibdir.h
|
|
echo '#define SHAREDINDEXFILE "$(sysconfdir)/shared/index"' >>htmllibdir.h
|
|
echo '#define SQWEBPASSWD "$(pkglibexecdir)/sqwebpasswd"' >>htmllibdir.h
|
|
- if test -d $(srcdir)/../courier \
|
|
+ if true || test -d $(srcdir)/../courier \
|
|
; then \
|
|
echo '#define HOSTNAMEFILE "$(sysconfdir)/defaultdomain"' >>htmllibdir.h \
|
|
; echo '#define MAKEMIME "$(bindir)/makemime"' >>htmllibdir.h \
|
|
@@ -1189,9 +1189,6 @@ install-perms-cache:
|
|
@echo "@cachedir@ 700 @cacheowner@ bin" >>permissions.dat
|
|
|
|
cache-reminder:
|
|
- -$(mkinstalldirs) $(DESTDIR)@cachedir@
|
|
- -$(mkinstalldirs) $(DESTDIR)$(piddir)
|
|
- test -w /etc || exit 0; chown @cacheowner@ $(DESTDIR)@cachedir@
|
|
@rm -f cron.cmd
|
|
@echo '#! @SHELL@' >cron.cmd
|
|
@echo 'su -p -c "$(scriptdir)/cleancache.pl" @cacheowner@' >>cron.cmd
|