89c9aae983
Install some libraries, as they are needed by x11/9term Move DEPENDS line in Makefile to shut up pkglint Bump version number to 4.3nb1
41 lines
1.1 KiB
Text
41 lines
1.1 KiB
Text
$NetBSD: patch-ab,v 1.3 2001/05/01 09:16:25 agc Exp $
|
|
|
|
--- libframe/Makefile.orig Tue May 1 09:42:03 2001
|
|
+++ libframe/Makefile Tue May 1 09:46:03 2001
|
|
@@ -1,21 +1,20 @@
|
|
# Copyright (c) 1992 AT&T - All rights reserved.
|
|
#
|
|
-# Prototype Makefile for libframe
|
|
+# Prototype BSDi Makefile for libframe
|
|
+# Courtesy of Boyd Roberts
|
|
+#
|
|
+# Define operating system type: -DBSDi
|
|
#
|
|
-# define operating system. ONE of:
|
|
-# -DIRIX -DSUNOS -DUMIPS -DSYSVR3 -DAIX -DOSF1
|
|
-# -DHPUX -DAPOLLO -DCONVEX -DDYNIX
|
|
-#
|
|
# Additionally, -D_POSIX_SOURCE (or its equivalent) may be specified
|
|
# if your compiler supports posix-compatible compilation
|
|
-OS=-DIRIX -ansiposix
|
|
+OS=-DBSDi -O2
|
|
|
|
# add -Iincludedir for any include directories that need to be searched
|
|
# for posix header files (for UMIPS, add -I/usr/include/posix)
|
|
-INCS=-I../include
|
|
+INCS=-I../include -I/usr/include/posix
|
|
|
|
# add name of library orderer - use ":" if none exists
|
|
-RANLIB=:
|
|
+RANLIB=ranlib
|
|
|
|
# add name of library
|
|
AR=ar
|
|
@@ -41,5 +40,7 @@
|
|
rm -f $(LIB)
|
|
|
|
install: $(LIB)
|
|
+ cp ${LIB} ${PREFIX}/lib/${LIB}
|
|
+ ${RANLIB} ${PREFIX}/lib/${LIB}
|
|
|
|
$(OBJ): ../include/u.h ../include/libc.h ../include/frame.h
|