for a terminal library. [in an ideal world, ncurses wouldn't even be listed, but according to the comments in configure.ac, some Linux distributions don't have libcurses, only libncurses, so it should stay.] fixes a problem when building with an external gcc, since gcc, when installed into /prefix, unconditionally searches /prefix/lib for libraries at link time causing it to find libncurses in /prefix/lib (the normal gcc ugliness). this leads to the runtime linker being unable to find libncurses. noted by gavan@, fix tested by gavan@ and myself.
13 lines
593 B
Text
13 lines
593 B
Text
$NetBSD: patch-ak,v 1.1 2003/07/09 13:11:02 grant Exp $
|
|
|
|
--- configure.orig Wed Jun 11 06:51:21 2003
|
|
+++ configure
|
|
@@ -6214,7 +6214,7 @@ build_os=`echo $ac_cv_build | sed 's/^\(
|
|
# rather ncurses. So we check for it.
|
|
TERMLIBS=
|
|
# Check for termlib before termcap because Solaris termcap needs libucb.
|
|
-TERMLIB_VARIANTS="ncurses curses termlib termcap terminfo"
|
|
+TERMLIB_VARIANTS="curses termlib termcap terminfo ncurses"
|
|
for termlib in ${TERMLIB_VARIANTS}; do
|
|
as_ac_Lib=`echo "ac_cv_lib_${termlib}''_tgetent" | $as_tr_sh`
|
|
echo "$as_me:$LINENO: checking for tgetent in -l${termlib}" >&5
|