pkgsrc/sysutils/xentools3/patches/patch-cf
bouyer f9a2cde352 Rename xentools30 to xentools3 to acknowledge that Xen dropped one digit
in version numbers, and upgrade to 3.1.0.
Changes since 3.0.4:
    *   XenAPI 1.0 support
          o XML configuration files for virtual machines;
          o VM life-cycle management operations; and
          o Secure on- or off-box XML-RPC with bindings for many languages
    * Basic save/restore/migrate support for HVM (e.g. Windows) VMs;
    * Dynamic memory control for HVM guests;
    * 32-on-64 PV guest support (run PAE PV VMs on a 64-bit Xen!); and
    * Blktap copy-on-write disk support.

It also fixes some HVM bugs.
2007-06-14 19:39:45 +00:00

21 lines
779 B
Text

$NetBSD: patch-cf,v 1.1.1.1 2007/06/14 19:39:46 bouyer Exp $
--- xenstat/libxenstat/Makefile.orig 2007-05-18 16:45:21.000000000 +0200
+++ xenstat/libxenstat/Makefile 2007-05-27 14:45:56.000000000 +0200
@@ -31,6 +31,7 @@
OBJECTS-y=src/xenstat.o
OBJECTS-$(CONFIG_Linux) += src/xenstat_linux.o
OBJECTS-$(CONFIG_SunOS) += src/xenstat_solaris.o
+OBJECTS-$(CONFIG_NetBSD) += src/xenstat_netbsd.o
SONAME_FLAGS=-Wl,$(SONAME_LDFLAG) -Wl,libxenstat.so.$(MAJOR)
WARN_FLAGS=-Wall -Werror
@@ -97,7 +98,7 @@
all-bindings: perl-bindings python-bindings
# The install-bindings target installs all the language bindings
-install-bindings: install-perl-bindings install-python-bindings
+install-bindings: install-python-bindings
$(BINDINGS): $(SHLIB) $(SHLIB_LINKS) src/xenstat.h