22 lines
920 B
Text
22 lines
920 B
Text
$NetBSD: patch-dh,v 1.2 2008/08/07 16:00:14 joerg Exp $
|
|
|
|
--- pygrub/Makefile.orig 2008-01-31 10:06:54.000000000 +0000
|
|
+++ pygrub/Makefile 2008-03-01 12:03:11.000000000 +0000
|
|
@@ -10,14 +10,12 @@ build:
|
|
|
|
.PHONY: install
|
|
ifndef XEN_PYTHON_NATIVE_INSTALL
|
|
-install: LIBPATH=$(shell PYTHONPATH=../python/xen/util python -c "import auxbin; print auxbin.libpath()")
|
|
+install: LIBPATH=$(shell PYTHONPATH=../py{}thon/xen/util python -c "import auxbin; print auxbin.libpath()")
|
|
install: all
|
|
- CC="$(CC)" CFLAGS="$(CFLAGS)" python setup.py install --home="$(DESTDIR)/usr" --prefix="" --install-lib="$(DESTDIR)$(LIBPATH)/python"
|
|
- $(INSTALL_DIR) $(DESTDIR)/var/run/xend/boot
|
|
+ python setup.py install --root=${DESTDIR}
|
|
else
|
|
install: all
|
|
- CC="$(CC)" CFLAGS="$(CFLAGS)" python setup.py install --root="$(DESTDIR)"
|
|
- $(INSTALL_DIR) $(DESTDIR)/var/run/xend/boot
|
|
+ python setup.py install --root=${DESTDIR}
|
|
endif
|
|
|
|
.PHONY: clean
|