4b5af82166
While here, do some pkglint cleanup. from Changelog: a) "mark" was changed like GNU Emacs from Ng 1.5alpha3. b) fix canna bug for UNIX. c) fix compile problem when libc was used for Human68K. from Officail Web page: patch) fix query-replace bug.
27 lines
641 B
Text
27 lines
641 B
Text
$NetBSD: patch-sys_sysv_Makefile,v 1.2 2012/12/12 12:04:51 wiz Exp $
|
|
|
|
Adapt canna flags for pkgsrc.
|
|
|
|
--- sys/sysv/Makefile.orig 2012-03-10 08:14:15.662278295 +0000
|
|
+++ sys/sysv/Makefile
|
|
@@ -15,12 +15,15 @@
|
|
SYS = sysv
|
|
|
|
# Canna configurations
|
|
-#CANNADEF = -DCANNA
|
|
-#CANNALIB = -L/usr/share/lib -lcanna
|
|
-#CANNAINC = -I/usr/share/include
|
|
+.if ${USE_CANNA} == "YES"
|
|
+CANNADEF = -DCANNA
|
|
+CANNALIB = ${LDFLAGS} -lcanna
|
|
+CANNAINC = ${CPPFLAGS}
|
|
+.else
|
|
CANNADEF =
|
|
-CANNALIB =
|
|
-CANNAINC =
|
|
+CANNALIB = ${LDFLAGS}
|
|
+CANNAINC = ${CPPFLAGS}
|
|
+.endif
|
|
|
|
# CDEFS gets defines, and gets passed to lint. CFLAGS gets flags, and doesn't
|
|
# get passed to lint.
|