Asterisk is a complete PBX in software. It provides all of the features you would expect from a PBX and more. Asterisk does voice over IP in three protocols, and can interoperate with almost all standards-based telephony equipment using relatively inexpensive hardware. Asterisk provides Voicemail services with Directory, Call Conferencing, Interactive Voice Response, Call Queuing. It has support for three-way calling, caller ID services, ADSI, SIP and H.323 (as both client and gateway). This is a standard version. It is scheduled to go to security fixes only on October 3th, 2018, and EOL on October 3th, 2019. See here for more information about Asterisk versions: https://wiki.asterisk.org/wiki/display/AST/Asterisk+Versions
44 lines
2.3 KiB
Text
44 lines
2.3 KiB
Text
$NetBSD: patch-configure.ac,v 1.1 2018/07/16 21:53:05 joerg Exp $
|
|
|
|
--- configure.ac.orig 2018-05-01 20:12:26.000000000 +0000
|
|
+++ configure.ac
|
|
@@ -745,7 +745,7 @@ AC_CHECK_HEADERS([xlocale.h])
|
|
|
|
AC_CHECK_HEADERS([winsock.h winsock2.h])
|
|
|
|
-AC_CHECK_HEADER([sys/poll.h],
|
|
+AC_CHECK_HEADER([poll.h],
|
|
[],
|
|
AC_DEFINE([AST_POLL_COMPAT], 1, [Define to 1 if internal poll should be used.]))
|
|
|
|
@@ -797,7 +797,7 @@ AC_FUNC_STRNLEN
|
|
AC_FUNC_STRTOD
|
|
AC_FUNC_UTIME_NULL
|
|
AC_FUNC_VPRINTF
|
|
-AC_CHECK_FUNCS([asprintf atexit closefrom dup2 eaccess endpwent euidaccess ffsll ftruncate getcwd gethostbyname gethostname getloadavg gettimeofday glob ioperm inet_ntoa isascii memchr memmove memset mkdir mkdtemp munmap newlocale ppoll putenv re_comp regcomp select setenv socket strcasecmp strcasestr strchr strcspn strdup strerror strlcat strlcpy strncasecmp strndup strnlen strrchr strsep strspn strstr strtod strtol strtold strtoq unsetenv uselocale utime vasprintf getpeereid sysctl swapctl])
|
|
+AC_CHECK_FUNCS([asprintf atexit closefrom dup2 eaccess endpwent euidaccess ffsll ftruncate getcwd gethostbyname gethostname getloadavg gettimeofday glob ioperm inet_ntoa isascii memchr memmove memset mkdir mkdtemp munmap newlocale ppoll putenv re_comp regcomp select setenv socket strcasecmp strcasestr strchr strcspn strdup strerror strftime_l strlcat strlcpy strptime_l strncasecmp strndup strnlen strrchr strsep strspn strstr strtod strtol strtold strtoq unsetenv uselocale utime vasprintf getpeereid sysctl swapctl])
|
|
|
|
AC_MSG_CHECKING(for htonll)
|
|
AC_LINK_IFELSE(
|
|
@@ -866,9 +866,9 @@ AC_SUBST(PBX_DYNAMIC_LIST)
|
|
LDFLAGS=${old_LDFLAGS}
|
|
rm -f conftest.dynamics
|
|
|
|
-AC_CHECK_HEADER([sys/poll.h],
|
|
+AC_CHECK_HEADER([poll.h],
|
|
[HAS_POLL=1]
|
|
- AC_DEFINE([HAVE_SYS_POLL_H], 1, [Define to 1 if your system has working sys/poll.h]),
|
|
+ AC_DEFINE([HAVE_SYS_POLL_H], 1, [Define to 1 if your system has working poll.h]),
|
|
)
|
|
|
|
AC_ARG_ENABLE([internal-poll],
|
|
@@ -1444,6 +1444,9 @@ AST_C_DEFINE_CHECK([IP_MTU_DISCOVER], [I
|
|
AC_CHECK_HEADER([libkern/OSAtomic.h],
|
|
[AC_DEFINE_UNQUOTED([HAVE_OSX_ATOMICS], 1, [Define to 1 if OSX atomic operations are supported.])])
|
|
|
|
+AC_CHECK_HEADER([sys/atomic.h],
|
|
+ [AC_DEFINE_UNQUOTED([HAVE_SYS_ATOMIC_H], 1, [Define to 1 if sys/atomic.h atomic operations are supported.])])
|
|
+
|
|
AC_CHECK_SIZEOF([int])
|
|
AC_CHECK_SIZEOF([long])
|
|
AC_CHECK_SIZEOF([long long])
|