47 lines
1.7 KiB
Text
47 lines
1.7 KiB
Text
$NetBSD: patch-ac,v 1.2 2012/06/09 06:28:58 dholland Exp $
|
|
|
|
- fix MAKE_JOBS issue
|
|
- fix thread handling
|
|
|
|
--- imap/Makefile.in.orig 2011-10-04 19:59:14.000000000 +0000
|
|
+++ imap/Makefile.in
|
|
@@ -124,7 +124,7 @@ BUILTSOURCES = imap_err.c imap_err.h pus
|
|
lmtpstats.c lmtpstats.h xversion.h mupdate_err.c mupdate_err.h \
|
|
nntp_err.c nntp_err.h
|
|
|
|
-all: xversion $(BUILTSOURCES) $(PROGS) $(SUIDPROGS)
|
|
+all: xversion $(BUILTSOURCES) .WAIT $(PROGS) $(SUIDPROGS)
|
|
|
|
pure: imapd.pure lmtpd.pure mupdate.pure
|
|
|
|
@@ -182,6 +182,9 @@ mupdate_err.c: mupdate_err.et
|
|
|
|
mupdate_err.h: mupdate_err.c
|
|
|
|
+mutex_pthread.o: mutex_pthread.c
|
|
+ $(CC) -c $(CPPFLAGS) $(DEFS) $(CFLAGS) $(PTHREAD_CFLAGS) $<
|
|
+
|
|
### Services
|
|
idled: idled.o mutex_fake.o libimap.a $(DEPLIBS)
|
|
$(CC) $(LDFLAGS) -o idled \
|
|
@@ -216,16 +219,16 @@ imapd.quant: $(IMAPDOBJS) mutex_fake.o l
|
|
|
|
mupdate: mupdate.o mupdate-slave.o mupdate-client.o mutex_pthread.o tls.o \
|
|
libimap.a $(DEPLIBS)
|
|
- $(CC) $(LDFLAGS) -o mupdate \
|
|
+ $(CC) $(LDFLAGS) $(PTHREAD_LDFLAGS) -o mupdate \
|
|
$(SERVICETHREAD) mupdate.o mupdate-slave.o mupdate-client.o \
|
|
mutex_pthread.o tls.o libimap.a \
|
|
- $(DEPLIBS) $(LIBS) $(LIB_WRAP) -lpthread
|
|
+ $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(PTHREAD_LIBS)
|
|
|
|
mupdate.pure: mupdate.o mupdate-slave.o mupdate-client.o mutex_pthread.o \
|
|
libimap.a $(DEPLIBS)
|
|
- $(PURIFY) $(PUREOPT) $(CC) $(LDFLAGS) -o mupdate.pure \
|
|
+ $(PURIFY) $(PUREOPT) $(CC) $(LDFLAGS) $(PTHREAD_LDFLAGS) -o mupdate.pure \
|
|
$(SERVICETHREAD) mupdate.o mupdate-slave.o mupdate-client.o \
|
|
- mutex_pthread.o libimap.a $(DEPLIBS) $(LIBS) $(LIB_WRAP) -lpthread
|
|
+ mutex_pthread.o libimap.a $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(PTHREAD_LIBS)
|
|
|
|
pop3d: pop3d.o proxy.o backend.o tls.o mutex_fake.o libimap.a \
|
|
$(DEPLIBS) $(SERVICE)
|