xscreensaver-demo program (which requires GTK). This is done to allow xscreensaver coexist with xscreensaver-gnome, and to avoid a dependancy on GTK when installing kdeartwork3. Changes since 4.13: * New hacks, `fontglide', `apple2', `xanalogtv', `pong', `gleidescope', `mirrorblob', and `blinkbox'. * New version of `glsnake' (with many more models.) * Another Windows crash in `bsod'; also HVX/GCOS6/TPS6. * New version of `endgame'. * Screen grabbing works on MacOS X. * Various minor fixes. Ok'ed by wiz@.
68 lines
4.2 KiB
Text
68 lines
4.2 KiB
Text
$NetBSD: patch-ad,v 1.11 2003/12/13 19:22:13 jmmv Exp $
|
|
|
|
--- driver/Makefile.in.orig 2003-10-25 09:47:19.000000000 +0200
|
|
+++ driver/Makefile.in
|
|
@@ -287,7 +287,7 @@ install-program: $(EXES)
|
|
fi ; \
|
|
echo $$inst xscreensaver $(install_prefix)$(bindir)/xscreensaver ; \
|
|
$$inst xscreensaver $(install_prefix)$(bindir)/xscreensaver
|
|
- @for exe in xscreensaver-command xscreensaver-demo \
|
|
+ @for exe in xscreensaver-command \
|
|
xscreensaver-getimage @EXES_OSX@ ; do \
|
|
echo $(INSTALL_PROGRAM) $$exe $(install_prefix)$(bindir)/$$exe ; \
|
|
$(INSTALL_PROGRAM) $$exe $(install_prefix)$(bindir)/$$exe ; \
|
|
@@ -462,7 +462,7 @@ install-pam:
|
|
fi ; \
|
|
fi
|
|
|
|
-install-gnome:: screensaver-properties.desktop
|
|
+xxxinstall-gnome:: screensaver-properties.desktop
|
|
@lost="" ;\
|
|
if [ "$(GNOME_DATADIR)" != "" ]; then \
|
|
\
|
|
@@ -470,10 +470,6 @@ install-gnome:: screensaver-properties.d
|
|
echo $(INSTALL_DIRS) "$(install_prefix)$(GNOME_CCDIR_1)" ;\
|
|
$(INSTALL_DIRS) "$(install_prefix)$(GNOME_CCDIR_1)" ;\
|
|
fi ;\
|
|
- if [ ! -d "$(install_prefix)$(GNOME_CCDIR_2)" ]; then \
|
|
- echo $(INSTALL_DIRS) "$(install_prefix)$(GNOME_CCDIR_2)" ;\
|
|
- $(INSTALL_DIRS) "$(install_prefix)$(GNOME_CCDIR_2)" ;\
|
|
- fi ;\
|
|
if [ ! -d "$(install_prefix)$(GNOME_CCDIR_3)" ]; then \
|
|
echo $(INSTALL_DIRS) "$(install_prefix)$(GNOME_CCDIR_3)" ;\
|
|
$(INSTALL_DIRS) "$(install_prefix)$(GNOME_CCDIR_3)" ;\
|
|
@@ -494,16 +490,6 @@ install-gnome:: screensaver-properties.d
|
|
fi ;\
|
|
\
|
|
echo $(INSTALL_DATA) screensaver-properties.desktop \
|
|
- $(install_prefix)$(GNOME_CCDIR_2)/screensaver-properties.desktop;\
|
|
- \
|
|
- if $(INSTALL_DATA) screensaver-properties.desktop \
|
|
- $(install_prefix)$(GNOME_CCDIR_2)/screensaver-properties.desktop;\
|
|
- then true ;\
|
|
- else \
|
|
- lost="$$lost $(install_prefix)$(GNOME_CCDIR_2)" ;\
|
|
- fi ;\
|
|
- \
|
|
- echo $(INSTALL_DATA) screensaver-properties.desktop \
|
|
$(install_prefix)$(GNOME_CCDIR_3)/screensaver-properties.desktop;\
|
|
\
|
|
if $(INSTALL_DATA) screensaver-properties.desktop \
|
|
@@ -537,7 +523,7 @@ install-gnome:: screensaver-properties.d
|
|
fi ;\
|
|
fi
|
|
|
|
-install-gnome:: screensaver-properties-capplet
|
|
+xxxinstall-gnome:: screensaver-properties-capplet
|
|
@if [ "$(GNOME_DATADIR)" != "" ]; then \
|
|
if [ ! -d "$(install_prefix)$(GNOME_BINDIR)" ]; then \
|
|
echo $(INSTALL_DIRS) "$(install_prefix)$(GNOME_BINDIR)" ;\
|
|
@@ -636,8 +622,6 @@ uninstall-gnome::
|
|
f=screensaver-properties.desktop ;\
|
|
echo rm -f $(install_prefix)$(GNOME_CCDIR_1)/$$f ;\
|
|
rm -f $(install_prefix)$(GNOME_CCDIR_1)/$$f ;\
|
|
- echo rm -f $(install_prefix)$(GNOME_CCDIR_2)/$$f ;\
|
|
- rm -f $(install_prefix)$(GNOME_CCDIR_2)/$$f ;\
|
|
echo rm -f $(install_prefix)$(GNOME_CCDIR_3)/$$f ;\
|
|
rm -f $(install_prefix)$(GNOME_CCDIR_3)/$$f ;\
|
|
echo rm -f $(install_prefix)$(GNOME_PANELDIR)/$$f ;\
|