pkgsrc/lang/openjdk8/patches/patch-jdk_test_Makefile
tnn c750282763 Import openjdk8-1.8.31 as lang/openjdk8.
Open-source implementation of the Java Platform, Standard Edition.
2015-02-08 08:41:25 +00:00

28 lines
844 B
Text

$NetBSD: patch-jdk_test_Makefile,v 1.1 2015/02/08 08:41:25 tnn Exp $
Use tools from pkgsrc.
--- jdk/test/Makefile.orig 2015-02-02 15:37:13.000000000 +0000
+++ jdk/test/Makefile
@@ -56,6 +56,8 @@ UNAME = uname
UNIQ = uniq
WC = wc
ZIP = zip
+UNZIP = unzip
+WHICH = which
# Get OS name from uname (Cygwin inexplicably adds _NT-5.1)
UNAME_S := $(shell $(UNAME) -s | $(CUT) -f1 -d_)
@@ -258,6 +260,12 @@ jdk_% core_% svc_%:
# ------------------------------------------------------------------
+# carry over XAUTHORITY
+JTREG_TEST_OPTIONS += -e:XAUTHORITY
+
+# some tests expect to find zip and unzip on the path
+JTREG_TEST_OPTIONS += -e:PATH=/bin:/usr/bin:$(dir $(shell $(WHICH) $(ZIP))):$(dir $(shell $(WHICH) $(UNZIP)))
+
ifdef CONCURRENCY
EXTRA_JTREG_OPTIONS += -concurrency:$(CONCURRENCY)
endif