pkgsrc/lang/neko/patches/patch-CMakeLists.txt
nia 70296178d5 lang: Add neko. Based on work by cfkoch in wip.
Neko is a high-level dynamically typed programming language. It can be used
as an embedded scripting language. It has been designed to provide a common
runtime for several different languages. Learning and using Neko is very
easy. You can easily extend the language with C libraries. You can also
write generators from your own language to Neko and then use the Neko
Runtime to compile, run, and access existing libraries.
2020-03-24 13:23:46 +00:00

15 lines
508 B
Text

$NetBSD: patch-CMakeLists.txt,v 1.1 2020/03/24 13:23:46 nia Exp $
Specify additional systems which do not use libdl.
--- CMakeLists.txt.orig 2018-12-22 14:27:53.412791761 -0800
+++ CMakeLists.txt 2018-12-22 14:28:10.004843917 -0800
@@ -360,7 +360,7 @@
target_link_libraries(nekovm libneko)
if(UNIX)
- if (NOT ${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
+ if (NOT ${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD" AND NOT ${CMAKE_SYSTEM_NAME} STREQUAL "NetBSD")
set(DL_LIB "dl")
endif()
find_package(Threads)