pkgsrc/lang/tcl-itcl/patches/patch-ae
jtb 2973df2fb0 Initial import of tcl-itcl. Package submitted by Mark Davies
<mark@MCS.VUW.AC.NZ> in PR pkg/12060. Some minor adjustments by me.

[incr Tcl] provides the extra language support needed to build large Tcl/Tk
applications. It introduces the notion of objects, which act as building
blocks for an application. Each object is a bag of data with a set of
procedures or "methods" that are used to manipulate it. Objects are organized
into "classes" with identical characteristics, and classes can inherit
functionality from one another. This object-oriented paradigm adds another
level of organization on top of the basic variable/procedure elements, and
the resulting code is easier to understand and maintain.
2001-02-23 20:36:24 +00:00

13 lines
517 B
Text

$NetBSD: patch-ae,v 1.1.1.1 2001/02/23 20:36:31 jtb Exp $
--- iwidgets2.2.0/Makefile.in.orig Tue Aug 29 15:58:00 2000
+++ iwidgets2.2.0/Makefile.in Thu Nov 9 17:34:21 2000
@@ -40,7 +40,7 @@
INSTALL_ROOT =
# Path name to use when installing library scripts:
-SCRIPT_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/lib/iwidgets$(VERSION)
+SCRIPT_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/lib/tcl/iwidgets$(VERSION)
# Directory in which to install the archive libtcl.a:
LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib