pkgsrc/lang/openjdk7/patches/patch-jdk_make_sun_security_ec_Makefile
2018-07-24 16:07:24 +00:00

22 lines
716 B
Text

$NetBSD: patch-jdk_make_sun_security_ec_Makefile,v 1.2 2018/07/24 16:07:25 jperkin Exp $
GCC compatability.
--- jdk/make/sun/security/ec/Makefile.orig 2017-08-13 05:55:16.000000000 +0000
+++ jdk/make/sun/security/ec/Makefile
@@ -188,6 +188,15 @@ ifeq ($(NATIVE_ECC_AVAILABLE), true)
#
OTHER_CFLAGS += -DMP_API_COMPATIBLE -DNSS_ECC_MORE_THAN_SUITE_B
+ # gcc on solaris seems to define _POSIX_C_SOURCE or _XOPEN
+ # g++, on the otherhand, does not define either.
+ # It causes problems with g++: _B_FALSE instead of B_FALSE
+ ifeq ($(PLATFORM), solaris)
+ ifeq ($(CC_VERSION), gcc)
+ OTHER_CFLAGS += -D__EXTENSIONS__
+ endif # CC_VERSION
+ endif # PLATFORM
+
#
# Libraries to link
#