pkgsrc/security/libprelude/patches/patch-ah
hasso 9d085e6bbb Update to 0.9.24. No normal upstream changelog except git log. Splitted up
the package to the base (with c++ bindings) and scripting languages bindings.
All hard work done by Rumko <rumcic at gmail.com>.
2009-08-23 18:56:34 +00:00

13 lines
930 B
Text

$NetBSD: patch-ah,v 1.1 2009/08/23 18:56:34 hasso Exp $
--- bindings/perl/Makefile.PL.in.orig 2009-07-24 19:55:09 +0300
+++ bindings/perl/Makefile.PL.in 2009-07-24 19:58:01 +0300
@@ -6,7 +6,7 @@ use Cwd "abs_path";
my %attributs = (NAME => 'PreludeEasy',
INC => '-I@top_srcdir@ -I@top_builddir@/src/include -I@top_srcdir@/src/include -I@top_builddir@/src/libprelude-error -I@top_srcdir@/bindings/c++/include -I@top_srcdir@/libmissing -I@top_builddir@/libmissing',
- LIBS => ["-L@top_builddir@/src/.libs -lprelude -L@top_builddir@/bindings/c++/.libs -lpreludecpp", "-L$ENV{LIBDIR} -lprelude @LIBPRELUDE_LIBS@ @LIBADD_DL@ @LTLIBTHREAD@" ],
+ LIBS => ["-L@top_builddir@/../.buildlink/lib -lprelude -lpreludecpp", "-L$ENV{LIBDIR} -lprelude @LIBPRELUDE_LIBS@ @LIBADD_DL@ @LTLIBTHREAD@" ],
LDDLFLAGS => "-L@top_builddir@/src/.libs $Config{lddlflags}");
if ( abs_path("@top_srcdir@") ne abs_path("@top_builddir@") ) {