f5a6a01648
- Include standard headers (stdlib.h, string.h, stdio.h) in misc.h to avoid conflicts with built-in declarations of functions. - Change CFLAGS= in Makefile to CFLAGS+= to use pkgsrc-provided CFLAGS. - Include termcap.buildlink3.mk to handle termcap properly. - Add DESTDIR support, use AUTO_MKDIRS. - Bump PKGREVISION. Now I can actually use it! ;)
59 lines
1.4 KiB
Text
59 lines
1.4 KiB
Text
$NetBSD: patch-aa,v 1.2 2008/07/09 05:02:06 bjs Exp $
|
|
|
|
--- Makefile.orig 1994-05-01 18:51:17.000000000 -0400
|
|
+++ Makefile
|
|
@@ -7,7 +7,7 @@
|
|
# name of the directory into which the binary should be installed
|
|
# used only when you use 'make install'
|
|
#
|
|
-INSDIR=/usr/local/bin
|
|
+INSDIR=${DESTDIR}${PREFIX}
|
|
|
|
#
|
|
# choose one from each of 1) 2) and 3) below
|
|
@@ -18,21 +18,21 @@ INSDIR=/usr/local/bin
|
|
# choose a) b) or c)
|
|
#
|
|
# a) for BSD derivitives, enable the following line
|
|
-#OSFLAG=
|
|
+OSFLAG=
|
|
|
|
# b) for XENIX systems, enable the following line
|
|
#OSFLAG=-DXENIX
|
|
|
|
# b) for other A.T.&T. UNIX derivitives, enable the following line
|
|
-OSFLAG=-DATT
|
|
+#OSFLAG=-DATT
|
|
|
|
#
|
|
# 2) SELECTION OF TERMINAL CONTROL LIBRARY
|
|
# choose either of a) b) or c)
|
|
#
|
|
# a) if you use termcap, enable the following lines
|
|
-#TFLAG=-DM_TERMCAP
|
|
-#TLIB=termcap
|
|
+TFLAG=-DM_TERMCAP
|
|
+TLIB=termcap
|
|
|
|
# b) if you are using terminfo on a XENIX machine, enable the following lines
|
|
#TFLAG=-DM_TERMINFO
|
|
@@ -44,8 +44,8 @@ OSFLAG=-DATT
|
|
#TLIB=curses
|
|
|
|
# d) NONE OF THE ABOVE
|
|
-TFLAG=
|
|
-TLIB=m # just a link to mathlib; quick hack to avoid fixing Makefile
|
|
+#TFLAG=
|
|
+#TLIB=m # just a link to mathlib; quick hack to avoid fixing Makefile
|
|
|
|
#
|
|
# 3) SELECTION OF WINDOW MANAGER AVAILABILITY
|
|
@@ -80,7 +80,7 @@ MANPAGE=spiff.1
|
|
# disable this line iff you like being honked at.
|
|
DEFS = -DNOCHATTER
|
|
|
|
-CFLAGS=-O $(OSFLAG) $(TFLAG) $(VISFLAG) $(DEFS)
|
|
+CFLAGS+=$(OSFLAG) $(TFLAG) $(VISFLAG) $(DEFS)
|
|
|
|
default: spiff
|
|
|