pkgsrc/net/csup/patches/patch-ab

41 lines
1.1 KiB
Text

$NetBSD: patch-ab,v 1.2 2007/02/20 13:31:19 joerg Exp $
--- Makefile.orig 2006-03-07 19:10:25.000000000 +0000
+++ Makefile
@@ -11,33 +11,13 @@ SRCS= attrstack.c config.c detailer.c di
globtree.c idcache.c keyword.c lister.c main.c misc.c mux.c parse.y \
pathcomp.c proto.c status.c stream.c threads.c token.l updater.c
-CFLAGS+= -I. -I${.CURDIR} -g -pthread -DHAVE_FFLAGS -DNDEBUG
+CFLAGS+= -I. -I${.CURDIR} -g ${PTHREAD_CFLAGS} -DHAVE_FFLAGS -DNDEBUG
+LDFLAGS+= ${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}
WARNS?= 6
-# A bit of tweaking is needed to get this Makefile working
-# with the bsd.prog.mk of all the *BSD OSes...
-.if (${UNAME} == "NetBSD")
-LDFLAGS+= -pthread
+# The NetBSD rules apply on all pkgsrc platforms.
YHEADER= yes
-.elif (${UNAME} == "OpenBSD")
-# I bet there's a better way to do this with the OpenBSD mk
-# framework but well, this works and I got bored.
-LDFLAGS+= -pthread
-YFLAGS= -d
-CLEANFILES+= parse.c parse.h y.tab.h
-
-config.c: parse.h
-
-token.l: parse.h
-
-y.tab.h: parse.c
-
-parse.h: y.tab.h
- cp ${.ALLSRC} ${.TARGET}
-
-.endif
-
DPADD= ${LIBCRYPTO} ${LIBZ}
LDADD= -lcrypto -lz