pkgsrc/cad/gwave/patches/patch-aj
dmcmahill ddeeeb7f29 - gcc3-ify (multi-line strings)
- be explicit about the location of graph (from plotutils) to help systems
  which have a graph program that doesn't work here.
2003-11-05 22:31:43 +00:00

18 lines
677 B
Text

$NetBSD: patch-aj,v 1.1 2003/11/05 22:31:43 dmcmahill Exp $
--- src/Makefile.am.orig 2003-08-02 03:24:45.000000000 -0400
+++ src/Makefile.am
@@ -32,10 +32,10 @@ BUILT_SOURCES=init_scheme_string.c scm_i
# $(DOT_DOC_FILES)
init_scheme_string.c: $(top_srcdir)/scheme/minimal.scm
- echo "char *init_scheme_string = \"\\" > $@
- sed -e 's/;.*$$//g' -e 's/"/\\"/g' -e "s/'/\\\\'/g" -e 's/$$/\\n\\/' < $(top_srcdir)/scheme/minimal.scm >> $@
+ echo "char *init_scheme_string = " > $@
+ sed -e 's/;.*$$//g' -e 's/"/\\"/g' -e "s/'/\\\\'/g" -e 's/$$/\\n"/' -e 's/^/"/g' < $(top_srcdir)/scheme/minimal.scm >> $@
echo >> $@
- echo '";' >> $@
+ echo ';' >> $@
SUFFIXES = .x .doc