3530f6ba5c
* Numerous bug fixes for most of the PAM modules, including several string length checks and fixes (update recommended!). * fix for legacy behavior of pam_setcred and pam_close_session in the case that pam_authenticate and pam_open_session hadn't been called * pam_unix: - don't zero out password strings during password changing function * pam_wheel: - feature: can use the module to provide wheel access to non-root accounts. * pam_limits: - added '%' domain for maxlogins limiting, now '*' and @group have the old meaning (every) and '%' the new one (all) - handle negative priority limits (which can apply to the superuser too). * pam_userdb: - require that all of typed password matches that in database * pam_access: - added the 'fieldsep=' argument, made a PAM_RHOST of "" equivalent to NULL Incidentally, cups-1.1.18 will once again do PAM authentication using pam_unix.so if built against PAM-0.77.
13 lines
565 B
Text
13 lines
565 B
Text
$NetBSD: patch-af,v 1.3 2002/12/23 21:23:58 jlam Exp $
|
|
|
|
--- libpamc/Makefile.orig Sat Feb 10 02:17:53 2001
|
|
+++ libpamc/Makefile
|
|
@@ -85,7 +85,7 @@ ifeq ($(DYNAMIC_LIBPAM),yes)
|
|
$(INSTALL) -m $(SHLIBMODE) $(LIBNAMED) $(FAKEROOT)$(libdir)/$(LIBNAMEDFULL)
|
|
$(LDCONFIG)
|
|
ifneq ($(DYNTYPE),"sl")
|
|
- ( cd $(FAKEROOT)$(libdir) ; rm -f $(LIBNAMED) ; ln -s $(LIBNAMEDNAME) $(LIBNAMED) )
|
|
+ ( cd $(FAKEROOT)$(libdir) ; rm -f $(LIBNAMED) $(LIBNAMEDNAME); ln -s $(LIBNAMEDFULL) $(LIBNAMED); ln -s $(LIBNAMEDFULL) $(LIBNAMEDNAME) )
|
|
endif
|
|
endif
|
|
ifeq ($(STATIC_LIBPAM),yes)
|