pkgsrc/devel/libgphoto2/patches/patch-ab
cube 7493aac55b Make this compile with gcc-2.95 (hi drochner!). Closes PR 24515.
bl3ify, and provide a buildlink3.mk file for future bl3ification of
dependencies.
2004-02-21 22:58:08 +00:00

21 lines
766 B
Text

$NetBSD: patch-ab,v 1.1 2004/02/21 22:58:08 cube Exp $
--- camlibs/aox/library.c.orig Sun Jan 18 19:47:00 2004
+++ camlibs/aox/library.c
@@ -202,6 +202,7 @@ get_file_func (CameraFilesystem *fs, con
gp_file_adjust_name_for_mime_type (file);
}
if ((w == 640)){
+ int header_len;
/* Stripping useless header */
p_data = data + 0x98;
/* Picture is mirror-imaged.*/
@@ -222,7 +223,7 @@ get_file_func (CameraFilesystem *fs, con
GP_DEBUG("size of data = %i\n", sizeof(data));
GP_DEBUG("size of p_data = %i\n", sizeof(p_data));
/* And now create a ppm file, with our own header */
- int header_len = snprintf(header, 127,
+ header_len = snprintf(header, 127,
"P6\n"
"# CREATOR: gphoto2, aox library\n"
"%d %d\n"