pkgsrc/www/seamonkey/patches/patch-mozilla_config_Makefile.in
ryoon 05bd7a8bf8 Update to 2.49.1
Changelog:
Based on Firefox 52.4.1

SeaMonkey-specific changes
    SeaMonkey should no longer crash when you start it or try to use the mail feature on OS X 10.12 or greater.
    You were not always prompted for authentication in SeaMonkey 2.48 under certain scenarios resulting in login failures. The problem, tracked in bug 1347857, has been fixed.
    Mail and News: The way images are included in a compose window has changed. Images are now included as data URIs and not as references to parts of other messages or operating system files. This allows better interoperability with office packages such as MS Office or LibreOffice. Images linked from locations on the internet will no longer be downloaded and attached to the message automatically. This can be changed globally by setting the preference mail.compose.attach_http_images.
    Language support for nb-NO has been re-added.
    SeaMonkey now uses gtk3 on Linux. If you experience a problem because of this please file a bug and link it to Switch Linux builds to GTK3 with SeaMonkey 2.49. Pleae try another OS theme first. Some of them are buggy and cause problems with SeaMonkey, Thunderbird and Firefox.
    Quotes are now colored differently in Mails bug 1374708.
    Under OSX the left panes in Bookmarks Manager, MailNews and Address Book are now styled like finder panes. See bug 1095904.
    Quotes are now colored differently in Mails up to 5 levels deep depending on your OS. See bug 1374708. This may break custom themes for email composition because a new style sheet named "messageQuotes.css" has been added.
2017-11-10 22:45:27 +00:00

25 lines
1.2 KiB
Text

$NetBSD: patch-mozilla_config_Makefile.in,v 1.8 2017/11/10 22:45:27 ryoon Exp $
--- mozilla/config/Makefile.in.orig 2017-10-16 07:17:07.000000000 +0000
+++ mozilla/config/Makefile.in
@@ -41,6 +41,8 @@ export:: $(export-preqs)
$(PYTHON) -m mozbuild.action.preprocessor $(DEFINES) $(ACDEFINES) \
-DMOZ_TREE_CAIRO=$(MOZ_TREE_CAIRO) \
-DMOZ_TREE_PIXMAN=$(MOZ_TREE_PIXMAN) \
+ -DMOZ_SYSTEM_GRAPHITE2=$(MOZ_SYSTEM_GRAPHITE2) \
+ -DMOZ_SYSTEM_HARFBUZZ=$(MOZ_SYSTEM_HARFBUZZ) \
-DMOZ_SYSTEM_HUNSPELL=$(MOZ_SYSTEM_HUNSPELL) \
-DMOZ_SYSTEM_BZ2=$(MOZ_SYSTEM_BZ2) \
-DMOZ_SYSTEM_ZLIB=$(MOZ_SYSTEM_ZLIB) \
@@ -49,6 +51,11 @@ export:: $(export-preqs)
-DMOZ_SYSTEM_LIBEVENT=$(MOZ_SYSTEM_LIBEVENT) \
-DMOZ_SYSTEM_LIBVPX=$(MOZ_SYSTEM_LIBVPX) \
-DMOZ_SYSTEM_ICU=$(MOZ_SYSTEM_ICU) \
+ -DMOZ_SYSTEM_OGG=$(MOZ_SYSTEM_OGG) \
+ -DMOZ_SYSTEM_THEORA=$(MOZ_SYSTEM_THEORA) \
+ -DMOZ_SYSTEM_VORBIS=$(MOZ_SYSTEM_VORBIS) \
+ -DMOZ_SYSTEM_TREMOR=$(MOZ_SYSTEM_TREMOR) \
+ -DMOZ_SYSTEM_SOUNDTOUCH=$(MOZ_SYSTEM_SOUNDTOUCH) \
$(srcdir)/system-headers $(srcdir)/stl-headers | $(PERL) $(topsrcdir)/nsprpub/config/make-system-wrappers.pl system_wrappers
$(INSTALL) system_wrappers $(DIST)