pkgsrc/devel/global/patches/patch-gozilla_Makefile.in
wiz 3fdb4d7dc2 Update to 6.3.3.
[CHANGES]
New facilities:
o Pygments plug-in parser: Support python 3.
o gozilla: added support of OSX's default browser.
  Please set environment variable BROWSER to 'osx-default'.

	$ htags --suggest --map-file
	$ export BROWSER=osx-default
	$ gozilla +120 main.c	# shows line 120 in main.c
	$ gozilla -d main	# shows definitions of main()

o vim74-gtags-cscope.patch: New patch for vim + gtags-cscope to treat
  file names which include spaces correctly. Please see README.PATCHES.

Release for beta test:
o Added --sqlite3 option which uses SQLite3 API instead of BSD/DB API for
  making tag files. If you will test the code then please do as follows:

	[configuration phase]
	$ ./configure --with-sqlite3	# use sqlite3 API

	[execution phase]
	$ gtags --sqlite3		# make sqlite3 tag files

[FIXED BUGS]
o gtags-cscope.vim: There was a calling to undefined function.
  Now it works.
2014-12-01 10:08:27 +00:00

17 lines
523 B
Text

$NetBSD: patch-gozilla_Makefile.in,v 1.1 2014/12/01 10:08:27 wiz Exp $
Add DESTDIR support.
--- gozilla/Makefile.in.orig 2014-11-26 02:49:49.000000000 +0000
+++ gozilla/Makefile.in
@@ -734,8 +734,8 @@ uninstall-man: uninstall-man1
uninstall-man1
install-data-hook:
- mkdir -p ${gtagsdir}
- chmod 777 ${gtagsdir}
+ mkdir -p ${DESTDIR}${gtagsdir}
+ chmod 777 ${DESTDIR}${gtagsdir}
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.