ff0f521542
Changes: * Fix CR at end of line in source file * Make the kalyptus script install with the executable bit set * Respect "EffectsEnabled" for tearoff handle setting
48 lines
1.6 KiB
Text
48 lines
1.6 KiB
Text
$NetBSD: patch-ce,v 1.5 2004/04/20 12:22:23 markd Exp $
|
|
|
|
--- kioslave/file/Makefile.in.orig 2004-04-06 03:12:31.000000000 +1200
|
|
+++ kioslave/file/Makefile.in
|
|
@@ -482,7 +482,7 @@ kdelnk_DATA = file.protocol
|
|
all: docs-am all-am
|
|
|
|
.SUFFIXES:
|
|
-.SUFFIXES: .cc .lo .o .obj
|
|
+.SUFFIXES: .cpp .cc .lo .o .obj
|
|
$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
|
|
#>- @for dep in $?; do \
|
|
#>- case '$(am__configure_deps)' in \
|
|
@@ -917,3 +917,34 @@ nmcheck:
|
|
file.lo: file.moc
|
|
nmcheck-am: nmcheck
|
|
file.o: file.moc
|
|
+
|
|
+# no optimization rules
|
|
+
|
|
+CXXCOMPILE_NOOPT=${CXXCOMPILE:-O%=}
|
|
+LTCXXCOMPILE_NOOPT=${LTCXXCOMPILE:-O%=}
|
|
+
|
|
+.cpp.o:
|
|
+@AMDEP_TRUE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
|
+@AMDEP_TRUE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
|
|
+@AMDEP_TRUE@ $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
|
+ $(CXXCOMPILE_NOOPT) -c -o $@ `test -f $< || echo '$(srcdir)/'`$<
|
|
+
|
|
+.cpp.obj:
|
|
+@AMDEP_TRUE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
|
|
+@AMDEP_TRUE@ depfile='$(DEPDIR)/$*.Po' tmpdepfile='$(DEPDIR)/$*.TPo' @AMDEPBACKSLASH@
|
|
+@AMDEP_TRUE@ $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
|
+ $(CXXCOMPILE_NOOPT) -c -o $@ `cygpath -w $<`
|
|
+
|
|
+.cpp.lo:
|
|
+@AMDEP_TRUE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
|
|
+@AMDEP_TRUE@ depfile='$(DEPDIR)/$*.Plo' tmpdepfile='$(DEPDIR)/$*.TPlo' @AMDEPBACKSLASH@
|
|
+@AMDEP_TRUE@ $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
|
+ $(LTCXXCOMPILE_NOOPT) -c -o $@ `test -f $< || echo '$(srcdir)/'`$<
|
|
+
|
|
+.cc.cpp:
|
|
+ cp -f $< $@
|
|
+
|
|
+# problem files when compiled with optimization
|
|
+
|
|
+file.lo: file.cpp
|
|
+file.o: file.cpp
|