271745887b
There was incompatible result by previous fix and it should be gone away. Beside ths security fix, ${PREFIX}/bin/phar.phar has correct shbang line. Bump PKGREVISION.
19 lines
947 B
Text
19 lines
947 B
Text
$NetBSD: patch-af,v 1.3 2011/06/22 09:54:35 taca Exp $
|
|
|
|
--- ext/phar/Makefile.frag.orig 2011-02-25 09:32:17.000000000 +0000
|
|
+++ ext/phar/Makefile.frag
|
|
@@ -18,7 +18,7 @@ PHP_PHARCMD_EXECUTABLE = ` \
|
|
else \
|
|
$(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; \
|
|
fi;`
|
|
-PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
|
|
+PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
|
|
|
|
$(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc
|
|
-@test -d $(builddir)/phar || mkdir $(builddir)/phar
|
|
@@ -39,4 +39,4 @@ install-pharcmd: pharcmd
|
|
-@$(mkinstalldirs) $(INSTALL_ROOT)$(bindir)
|
|
$(INSTALL) $(builddir)/phar.phar $(INSTALL_ROOT)$(bindir)
|
|
-@rm -f $(INSTALL_ROOT)$(bindir)/phar
|
|
- $(LN_S) -f $(bindir)/phar.phar $(INSTALL_ROOT)$(bindir)/phar
|
|
+ $(LN_S) -f phar.phar $(INSTALL_ROOT)$(bindir)/phar
|