f3a79729be
* No changelog available.
19 lines
645 B
Text
19 lines
645 B
Text
$NetBSD: patch-ae,v 1.2 2010/08/27 06:11:50 adam Exp $
|
|
|
|
--- configure.ac.orig 2010-02-17 15:56:16.000000000 +0000
|
|
+++ configure.ac
|
|
@@ -200,12 +200,12 @@ dnl Checks for libraries.
|
|
|
|
dnl Thread related checks
|
|
AC_CHECK_HEADER(pthread.h)
|
|
-AC_SEARCH_LIBS(pthread_exit, [pthread c_r])
|
|
+AC_SEARCH_LIBS(pthread_create, [pthread c_r])
|
|
if test "x$ac_cv_header_pthread_h" = "xyes"; then
|
|
CXXFLAGS="$CXXFLAGS -D_REENTRANT"
|
|
CFLAGS="$CFLAGS -D_REENTRANT"
|
|
|
|
- if test "x$ac_cv_search_pthread_exit" = "x-lc_r"; then
|
|
+ if test "x$ac_cv_search_pthread_create" = "x-lc_r"; then
|
|
CXXFLAGS="-pthread $CXXFLAGS"
|
|
CFLAGS="-pthread $CFLAGS"
|
|
fi
|