pkgsrc/www/apache2/patches/patch-aa

83 lines
2.7 KiB
Text

$NetBSD: patch-aa,v 1.10 2003/05/29 01:02:29 itojun Exp $
--- Makefile.in.orig 2003-05-18 02:11:37.000000000 +0900
+++ Makefile.in 2003-05-29 09:48:23.000000000 +0900
@@ -14,7 +14,7 @@
PROGRAMS = $(PROGRAM_NAME)
TARGETS = $(PROGRAMS) $(shared_build) $(other_targets)
PHONY_TARGETS = $(srcdir)/buildmark.c
-INSTALL_TARGETS = install-conf install-htdocs install-error install-icons \
+INSTALL_TARGETS = install-htdocs install-error install-icons \
install-other install-cgi install-include install-suexec install-man \
install-build
@@ -71,6 +71,7 @@
< $$i; \
fi \
) > $(DESTDIR)$(sysconfdir)/$$i; \
+ if false; then \
chmod 0644 $(DESTDIR)$(sysconfdir)/$$i; \
file=`echo $$i|sed s/-std//`; \
if [ "$$file" = "httpd.conf" ]; then \
@@ -79,13 +80,16 @@
if test "$$file" != "$$i" && test ! -f $(DESTDIR)$(sysconfdir)/$$file; then \
$(INSTALL_DATA) $(DESTDIR)$(sysconfdir)/$$i $(DESTDIR)$(sysconfdir)/$$file; \
fi; \
+ fi; \
done ; \
done ; \
if test -f "$(builddir)/envvars-std"; then \
cp -p envvars-std $(DESTDIR)$(sbindir); \
+ if false; then \
if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
fi ; \
+ fi ; \
fi
install-build:
@@ -93,8 +97,6 @@
@test -d $(DESTDIR)$(installbuilddir) || $(MKINSTALLDIRS) $(DESTDIR)$(installbuilddir)
@cp $(top_srcdir)/build/*.mk $(DESTDIR)$(installbuilddir); \
cp build/*.mk $(DESTDIR)$(installbuilddir); \
- sed 's#LIBTOOL = \(.*\)#LIBTOOL = $(SHELL) $(installbuilddir)/libtool $(LTFLAGS)#' \
- build/config_vars.mk > $(DESTDIR)$(installbuilddir)/config_vars.mk; \
cp $(top_srcdir)/build/instdso.sh $(DESTDIR)$(installbuilddir);
htdocs-srcdir = $(top_srcdir)/docs/docroot
@@ -107,7 +109,7 @@
doxygen $(top_srcdir)/docs/doxygen.conf
install-htdocs:
- -@if [ -d $(DESTDIR)$(htdocsdir) ]; then \
+ -@if false; then \
echo "[PRESERVING EXISTING HTDOCS SUBDIR: $(DESTDIR)$(htdocsdir)]"; \
else \
echo Installing HTML documents ; \
@@ -117,7 +119,7 @@
fi
install-error:
- -@if [ -d $(DESTDIR)$(errordir) ]; then \
+ -@if false; then \
echo "[PRESERVING EXISTING ERROR SUBDIR: $(DESTDIR)$(errordir)]"; \
else \
echo Installing error documents ; \
@@ -127,7 +129,7 @@
fi
install-icons:
- -@if [ -d $(DESTDIR)$(iconsdir) ]; then \
+ -@if false; then \
echo "[PRESERVING EXISTING ICONS SUBDIR: $(DESTDIR)$(iconsdir)]"; \
else \
echo Installing icons ; \
@@ -137,7 +139,7 @@
fi
install-cgi:
- -@if [ -d $(DESTDIR)$(cgidir) ];then \
+ -@if false; then \
echo "[PRESERVING EXISTING CGI SUBDIR: $(DESTDIR)$(cgidir)]"; \
else \
echo Installing CGIs ; \