pkgsrc/audio/jack/patches/patch-ap
bjs 1d500c5f48 Update to jack-0.115.1 (from SVN). Changes: pulled in a patch
to [hopefully] correct errant behavior wrt: non-blocking I/O and sockets.
This is presently untested, however.  Also, with this snapshot
we at least have the hope that the network facility works.  Includes
other miscellaneous bug fixes, also.

While here, explicitly enable coreaudio on Darwin and add a PLIST
entry for its driver module.  This is also untested, but at least
installation on Darwin will not fail due to an incorrect PLIST.  Also,
include ../../mk/dlopen.buildlink3.mk in our bl3.mk in order
to heed DLOPEN_REQUIRE_PTHREADS.
2008-11-16 11:22:55 +00:00

13 lines
295 B
Text

$NetBSD: patch-ap,v 1.2 2008/11/16 11:22:55 bjs Exp $
--- jack/types.h.orig 2008-11-11 17:36:38.000000000 -0500
+++ jack/types.h
@@ -23,7 +23,7 @@
#include <inttypes.h>
-typedef int32_t jack_shmsize_t;
+typedef size_t jack_shmsize_t;
/**
* Type used to represent sample frame counts.