pkgsrc/audio/jack/patches/patch-as
bjs 1d500c5f48 Update to jack-0.115.1 (from SVN). Changes: pulled in a patch
to [hopefully] correct errant behavior wrt: non-blocking I/O and sockets.
This is presently untested, however.  Also, with this snapshot
we at least have the hope that the network facility works.  Includes
other miscellaneous bug fixes, also.

While here, explicitly enable coreaudio on Darwin and add a PLIST
entry for its driver module.  This is also untested, but at least
installation on Darwin will not fail due to an incorrect PLIST.  Also,
include ../../mk/dlopen.buildlink3.mk in our bl3.mk in order
to heed DLOPEN_REQUIRE_PTHREADS.
2008-11-16 11:22:55 +00:00

23 lines
817 B
Text

$NetBSD: patch-as,v 1.2 2008/11/16 11:22:55 bjs Exp $
--- drivers/dummy/dummy_driver.c.orig 2008-11-11 17:36:45.000000000 -0500
+++ drivers/dummy/dummy_driver.c
@@ -109,6 +109,7 @@ dummy_driver_wait (dummy_driver_t *drive
{
jack_nframes_t nframes = driver->period_size;
struct timespec now;
+ struct timespec ts;
*status = 0;
/* this driver doesn't work so well if we report a delay */
@@ -133,7 +134,9 @@ dummy_driver_wait (dummy_driver_t *drive
}
driver->next_wakeup = add_ts(driver->next_wakeup, driver->wait_time);
} else {
- if(clock_nanosleep(CLOCK_REALTIME, TIMER_ABSTIME, &driver->next_wakeup, NULL)) {
+ ts.tv_sec = 0;
+ ts.tv_nsec = ts_to_nsec(driver->next_wakeup) - ts_to_nsec(now);
+ if(nanosleep(&ts, NULL)) {
jack_error("error while sleeping");
*status = -1;
} else {