While here: - sprinkle stdlib.h widely to avoid undefined behavior calling malloc - fix randomizer setup (was calling srand() and then using random()) - avoid installing a csh script, since we were replacing the entire contents of the file anyhow - add missing libXt and libX11 bl3.mk - add patch comments PKGREVISION -> 4.
15 lines
342 B
Text
15 lines
342 B
Text
$NetBSD: patch-traio_c,v 1.1 2012/06/16 04:00:54 dholland Exp $
|
|
|
|
Use standard headers.
|
|
|
|
--- traio.c~ 1993-07-14 11:02:15.000000000 +0000
|
|
+++ traio.c
|
|
@@ -15,7 +15,7 @@
|
|
#include "celltype.h"
|
|
#include "netsize.h"
|
|
#include <stdio.h>
|
|
-
|
|
+#include <stdlib.h>
|
|
|
|
#define DEFAULT_TRAN_X_DISP -HA_STE_RAD
|
|
#define DEFAULT_TRAN_Y_DISP -HA_STE_RAD-5
|