pkgsrc/graphics/jasper/patches/patch-CMakeLists.txt
adam 14731c87d6 jasper: updated to 2.0.20
2.0.20

* fixed several ISO/IEC 15444-4 conformance bugs

* fixed new variant of CVE-2016-9398

* disabled the MIF codec by default for security reasons (but it is still
  included in the library);
  in a future release, the MIF codec may also be excluded from the
  library by default

* added documentation for the I/O streams library API
2020-09-14 17:47:13 +00:00

18 lines
611 B
Text

$NetBSD: patch-CMakeLists.txt,v 1.5 2020/09/14 17:47:14 adam Exp $
Remove the weird hack.
--- CMakeLists.txt.orig 2020-09-05 14:52:22.000000000 +0000
+++ CMakeLists.txt
@@ -57,11 +57,7 @@ set(JAS_SO_MINOR 0)
set(JAS_SO_RELEASE 0)
# This is a temporary hack for OSX that should be removed when JAS_SO_VERSION
# is next incremented.
-if (MACOSX)
-set(JAS_SO_NAME "5.${JAS_SO_MINOR}.${JAS_SO_RELEASE}")
-else()
set(JAS_SO_NAME "${JAS_SO_VERSION}.${JAS_SO_MINOR}.${JAS_SO_RELEASE}")
-endif()
message("Shared library ABI version: ${JAS_SO_VERSION}")
message("Shared library build version: ${JAS_SO_NAME}")