pkgsrc/devel/jq/patches/patch-compile.c
leot dd1fb69f10 jq: Update devel/jq to 1.6
pkgsrc changes:
 - Use GITHUB_RELEASE instead of GITHUB_TAG because the former does not need
   auto* tools (despite we need auto* tools for patches/, hopefully one day they
   will be applied!)
 - Remove no longer needed SUBST_*, `git describe' is no longer used
 - Remove patch-src_jv__parse.c and patch-src_jv__print.c, they are
   present in 1.6
 - Rename and readjust patch-Makefile.in to patch-Makefile.am
   (pre-configure target rewrote it due `autoreconf')

Changes:
1.6
---
New in this release since 1.5:
- Destructuring Alternation
- New Builtins:
   * builtins/0
   * stderr/0
   * halt/0, halt_error/1
   * isempty/1
   * walk/1
   * utf8bytelength/1
   * localtime/0, strflocaltime/1
   * SQL-style builtins
   * and more!
- Add support for ASAN and UBSAN
- Make it easier to use jq with shebangs (8f6f28c)
- Add $ENV builtin variable to access environment
- Add JQ_COLORS env var for configuring the output colors

Bug fixes:
- Calling jq without a program argument now always assumes . for the program,
  regardless of stdin/stdout. (5fe0536)
- Make sorting stable regardless of qsort. (7835a72)
- Adds a local oniguruma submodule and the
  `./configure --with-oniguruma=builtin' option to make it easier to build
  with oniguruma support on systems where you can't install system-level
  libraries. (c6374b6 and 02bad4b)
- And much more!
2018-11-03 12:47:16 +00:00

22 lines
728 B
C

$NetBSD: patch-compile.c,v 1.2 2018/11/03 12:47:16 leot Exp $
Defining _GNU_SOURCE, _BSD_SOURCE etc. in C sources is problematic,
because the result of the configure command may be inconsistent with it.
to be consistent, such macros have to be defined in the early stage of
the configure command, and the AC_USE_SYSTEM_EXTENSIONS macro does the job.
Part of pull request 1458, commit id `df9a0963f8fa6fca773b059dce22c598152f3edb':
<https://github.com/stedolan/jq/pull/1458>
Also shared via PR pkg/52460.
--- src/compile.c.orig 2015-08-18 04:25:04.000000000 +0000
+++ src/compile.c
@@ -1,6 +1,3 @@
-#ifndef _GNU_SOURCE
-#define _GNU_SOURCE // for strdup
-#endif
#include <assert.h>
#include <math.h>
#include <string.h>