pkgsrc/security/policykit/patches/patch-am
sketch 77f91ca050 The Solaris support in this package only works on OpenSolaris. Allow it to
build (although likely not work) on Solaris too.
2009-01-20 10:08:17 +00:00

25 lines
723 B
Text

$NetBSD: patch-am,v 1.2 2009/01/20 10:08:17 sketch Exp $
--- configure.in.orig Mon Jun 30 20:40:59 2008
+++ configure.in Tue Jan 20 09:42:26 2009
@@ -521,6 +521,11 @@
;;
*solaris*)
AC_DEFINE([HAVE_SOLARIS], 1, [Is this a Solaris system?])
+ case "`uname -s`" in
+ 5.11)
+ AC_DEFINE([HAVE_OPENSOLARIS], 1, [Is this an OpenSolaris system?])
+ ;;
+ esac
;;
*freebsd*)
AC_DEFINE([HAVE_FREEBSD], 1, [Is this a FreeBSD system?])
@@ -528,7 +533,7 @@
esac
have_inotify=no
-AC_CHECK_HEADERS([linux/inotify.h], [have_inotify=yes])
+#AC_CHECK_HEADERS([linux/inotify.h], [have_inotify=yes])
AC_CHECK_HEADERS([sys/inotify.h], [have_inotify=yes])
AM_CONDITIONAL(HAVE_INOTIFY, test "x$have_inotify" = "xyes")