8b67a7cd92
fix the SmartOS bulk build (which gave similar errors, but which I couldn't reproduce on my SmartOS or Tribblix systems). Does not break: - macOS 12.1 - NetBSD 9.2 and -current - OpenBSD 7.0 - FreeBSD 13.0 - Tribblix m25.1 - CentOS 7 and 8 - Debian 9, 10, and 11 - Devuan 4 - Ubuntu 14, 16, 18, and 20 - Void
15 lines
478 B
Text
15 lines
478 B
Text
$NetBSD: patch-magic_Makefile.in,v 1.2 2021/12/27 23:25:08 schmonz Exp $
|
|
|
|
Use the just-built libmagic, not whatever might be already installed.
|
|
|
|
--- magic/Makefile.in.orig 2021-03-31 00:22:07.000000000 +0000
|
|
+++ magic/Makefile.in
|
|
@@ -850,7 +850,7 @@ ${MAGIC}: $(EXTRA_DIST) $(FILE_COMPILE_D
|
|
exit 1; \
|
|
fi; \
|
|
fi)
|
|
- $(FILE_COMPILE) -C -m magic
|
|
+ chmod +x myfile && ./myfile magic
|
|
@rm -fr magic
|
|
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|