Pkgsrc changes: * Adapt patches to match new files. * Add new migration scripts to PLIST Upstream changes: News * Support for RFC5011 style KSK rollovers. KSK section in the KASP now accepts element. * Enforcer: New repository option allows to generate keys with CKA_EXTRACTABLE attribute set to TRUE so keys can be wrapped and extracted from HSM. Bugfixes * SUPPORT-145: EOF handling an ARM architecture caused signer to hang. * Fixed signer hitting assertion on short reply XFR handler. * Include revoke bit in keytag calculation. * Increased stacksize on some systems (thanks Patrik Lundin!). * Stop ods-signerd on SIGINT. Note: * Updating from earlier versions of OpenDNSSEC requires use of the database migration script(s) included in ${PKG}/share/opendnssec/ as the migrate_1_4_8* scripts.
15 lines
517 B
Text
15 lines
517 B
Text
$NetBSD: patch-enforcer_utils_Makefile.am,v 1.2 2015/11/16 10:09:08 he Exp $
|
|
|
|
Install the conversion scripts.
|
|
|
|
--- enforcer/utils/Makefile.am.orig 2015-10-05 14:19:26.000000000 +0000
|
|
+++ enforcer/utils/Makefile.am
|
|
@@ -43,3 +43,8 @@ EXTRA_DIST += $(srcdir)/convert_database
|
|
EXTRA_DIST += $(srcdir)/migrate_zone_delete.mysql
|
|
EXTRA_DIST += $(srcdir)/migrate_1_4_8.*
|
|
|
|
+install-data-local: $(EXTRA_DIST)
|
|
+ for f in $(EXTRA_DIST); do \
|
|
+ $(INSTALL_DATA) "$$f" $(DESTDIR)$(opendnssecdatadir) \
|
|
+ || exit $$?; \
|
|
+ done
|