1b4fe7e36a
I got many patches integrated upstream, still more to go. Core Release v1.1.1 Define some types if missing Define EBADFD in terms of EBADF if it doesn't exist. Control API control: keep consistent usage of assertion control: initialize element channel values according to identification number at adding a new element control: fulfill a description about element type with integer64 coverity fixes control: add missing asserts to ctl_elem_set functions PCM API pcm: fix 'unable to create IPC shm instance' caused by fork from a thread Introduce bswap.h for portable definitions of byte swap macros. coverity fixes pcm_hw: fix possible memory leak (coverity) pcm: simple: Fix asserts Sequencer API seq: Provide sequencer sound card number / PID via alsa-lib Timer API Only use F_SETSIG fcntl where it exists. Topology API topology: Add support for widget byte controls topology: add support for CTL access flags to config file topology: add support for pasring external ops in conf files topology: Add ops to bytes control. topology: Remove unnecessary includes topology: fix debug output to print correct "max" value. topology: Quit and show error message on big-endian machines topology: Not compare a for loop iterator with ABI __le32 variables topology: Fix comparison of unsigned expression < 0 topology: Remove unused variables topology: Remove unused function write_data_block() topology: open topology files with O_TRUNC topology: Add missing include sys/stat.h Use Case Manager API Use alphasort where versionsort is not available. /include/Makefile.am Introduce bswap.h for portable definitions of byte swap macros. Define some types if missing ALSA Server coverity fixes Compatibility routines Add more compatibility defines. Introduce bswap.h for portable definitions of byte swap macros. Define some types if missing Configuration Use alphasort where versionsort is not available. config files - do not include ucm/topology configuration when not requested Kernel Headers seq: Provide sequencer sound card number / PID via alsa-lib Update include/sound/asequencer.h from 4.6-pre kernel uapi Update include/sound/asound.h from 4.6-pre kernel uapi
13 lines
317 B
Text
13 lines
317 B
Text
$NetBSD: patch-ah,v 1.4 2016/04/15 08:47:50 wiz Exp $
|
|
|
|
--- src/pcm/pcm.c.orig 2013-07-08 12:31:36.000000000 +0000
|
|
+++ src/pcm/pcm.c
|
|
@@ -630,7 +630,7 @@ playback devices.
|
|
|
|
#include <stdio.h>
|
|
#include <string.h>
|
|
-#include <malloc.h>
|
|
+#include <stdlib.h>
|
|
#include <stdarg.h>
|
|
#include <signal.h>
|
|
#include <ctype.h>
|