abaab46bba
* Accept python27 * Support debug build and target for debugging Mostly from richard@.
85 lines
3.7 KiB
Text
85 lines
3.7 KiB
Text
$NetBSD: patch-configure.ac,v 1.5 2014/06/22 23:59:36 ryoon Exp $
|
|
|
|
* Improve portability, replace == with =
|
|
* Detect pkgsrc apache-ant library
|
|
* Fix installation directory
|
|
|
|
--- configure.ac.orig 2014-04-30 19:49:45.000000000 +0000
|
|
+++ configure.ac
|
|
@@ -611,6 +611,8 @@ aix*)
|
|
|
|
openbsd*)
|
|
test_gtk=yes
|
|
+ build_gstreamer=yes
|
|
+ build_gstreamer_0_10=yes
|
|
test_tde=yes
|
|
test_kde=yes
|
|
test_freetype=yes
|
|
@@ -6344,7 +6346,7 @@ if test \( "$_os" != "WINNT" -o "$WITH_M
|
|
|
|
# Assume visibility is not broken with libc++. The below test is very much designed for libstdc++
|
|
# only.
|
|
- if test "$HAVE_GCC_VISIBILITY_FEATURE" = "TRUE" -a "$CPP_LIBRARY" = GLIBCXX; then
|
|
+ if test "$HAVE_GCC_VISIBILITY_FEATURE" = "TRUE" -a "$CPP_LIBRARY" = GLIBCXX -a "$COM_GCC_IS_CLANG" != "TRUE"; then
|
|
dnl gcc#19664, gcc#22482, rhbz#162935
|
|
AC_MSG_CHECKING([if STL headers are visibility safe (GCC bug 22482)])
|
|
AC_EGREP_HEADER(visibility push, string, stlvisok=yes, stlvisok=no)
|
|
@@ -7986,7 +7988,7 @@ no|disable)
|
|
else
|
|
# Unset variables set by the above AM_PATH_PYTHON so that
|
|
# we actually do check anew.
|
|
- unset PYTHON am_cv_pathless_PYTHON ac_cv_path_PYTHON am_cv_python_version am_cv_python_platform am_cv_python_pythondir am_cv_python_pyexecdir
|
|
+ #unset PYTHON am_cv_pathless_PYTHON ac_cv_path_PYTHON am_cv_python_version am_cv_python_platform am_cv_python_pythondir am_cv_python_pyexecdir
|
|
AM_PATH_PYTHON([3.3],, [:])
|
|
if test "$PYTHON" = :; then
|
|
AC_MSG_RESULT([internal])
|
|
@@ -8039,9 +8041,9 @@ if test $enable_python = system; then
|
|
elif test "$cross_compiling" != yes; then
|
|
# Unset variables set by the above AM_PATH_PYTHON so that
|
|
# we actually do check anew.
|
|
- unset PYTHON am_cv_pathless_PYTHON ac_cv_path_PYTHON am_cv_python_version am_cv_python_platform am_cv_python_pythondir am_cv_python_pyexecdir
|
|
+ #unset PYTHON am_cv_pathless_PYTHON ac_cv_path_PYTHON am_cv_python_version am_cv_python_platform am_cv_python_pythondir am_cv_python_pyexecdir
|
|
# This causes an error if no python command is found
|
|
- AM_PATH_PYTHON([3.3])
|
|
+ AM_PATH_PYTHON([2.6])
|
|
python_include=`$PYTHON -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('INCLUDEPY'));"`
|
|
python_version=`$PYTHON -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('VERSION'));"`
|
|
python_libs=`$PYTHON -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('LIBS'));"`
|
|
@@ -8929,7 +8931,7 @@ SYSTEM_GENBRK=
|
|
SYSTEM_GENCCODE=
|
|
SYSTEM_GENCMN=
|
|
|
|
-ICU_MAJOR=52
|
|
+ICU_MAJOR=53
|
|
ICU_MINOR=1
|
|
ICU_RECLASSIFIED_CLOSE_PARENTHESIS="YES"
|
|
ICU_RECLASSIFIED_PREPEND_SET_EMPTY="YES"
|
|
@@ -9788,8 +9790,8 @@ if test -z "$PATCH"; then
|
|
AC_MSG_ERROR([\"patch\" not found in \$PATH, install it])
|
|
fi
|
|
|
|
-dnl On Solaris, FreeBSD or MacOS X, check if --with-gnu-patch was used
|
|
-if test "$_os" = "SunOS" -o "$_os" = "FreeBSD" -o "$_os" = "Darwin"; then
|
|
+dnl On Solaris, or MacOS X, check if --with-gnu-patch was used
|
|
+if test "$_os" = "SunOS" -o "$_os" = "Darwin"; then
|
|
if test -z "$with_gnu_patch"; then
|
|
GNUPATCH=$PATCH
|
|
else
|
|
@@ -11954,7 +11956,7 @@ EOF
|
|
dnl Checking for ant.jar
|
|
if test "$ANT_HOME" != "NO_ANT_HOME"; then
|
|
AC_MSG_CHECKING([Ant lib directory])
|
|
- if test -f $ANT_HOME/lib/ant.jar; then
|
|
+ if test -f $ANT_HOME/lib/java/ant/ant.jar; then
|
|
ANT_LIB="$ANT_HOME/lib"
|
|
else
|
|
if test -f $ANT_HOME/ant.jar; then
|
|
@@ -12370,7 +12372,7 @@ AC_SUBST(MANDIR)
|
|
DOCDIR=[$(eval echo $(eval echo $docdir))]
|
|
AC_SUBST(DOCDIR)
|
|
|
|
-INSTALLDIR="$LIBDIR/$INSTALLDIRNAME"
|
|
+INSTALLDIR="$PREFIXDIR"
|
|
AC_SUBST(INSTALLDIR)
|
|
|
|
TESTINSTALLDIR="${BUILDDIR}/test-install"
|