pkgsrc/databases/qdbm/patches/patch-af
obache cec9995212 Update qdbm to 1.8.78.
2007-12-22  Mikio Hirabayashi  <mikio@fallabs.com>

	- Converters from Depot/Curia/Villa to TCHDB/TCBDB were added.

	- Release: 1.8.78
2014-05-31 07:28:57 +00:00

35 lines
1.3 KiB
Text

$NetBSD: patch-af,v 1.5 2014/05/31 07:28:57 obache Exp $
* pkgsrc layout style
* prevent to overwrite with unwanted hard coded variables
* install modules as vendor.
--- ruby/Makefile.in.orig 2006-09-06 03:37:33.000000000 +0000
+++ ruby/Makefile.in
@@ -21,11 +21,11 @@ MYDOCS = rbspex.html rbspex-ja.html rbap
prefix = @prefix@
exec_prefix = @exec_prefix@
MYBINDIR = @bindir@
-MYDATADIR = @datadir@/$(PACKAGE)/ruby
+MYDATADIR = @datadir@/doc/$(PACKAGE)/ruby
DESTDIR =
# Building binaries
-RUNENV = LD_LIBRARY_PATH=.:..:../..:/usr/local/lib
+RUNENV = LD_LIBRARY_PATH=.:..:../..
@@ -35,9 +35,9 @@ RUNENV = LD_LIBRARY_PATH=.:..:../..:/usr
all :
- cd depot && [ -f Makefile ] || $(RUNENV) ruby extconf.rb ; $(RUNENV) make
- cd curia && [ -f Makefile ] || $(RUNENV) ruby extconf.rb ; $(RUNENV) make
- cd villa && [ -f Makefile ] || $(RUNENV) ruby extconf.rb ; $(RUNENV) make
+ cd depot && [ -f Makefile ] || $(RUNENV) $(RUBY) extconf.rb $(RUBY_EXTCONF_ARGS); $(RUNENV) make
+ cd curia && [ -f Makefile ] || $(RUNENV) $(RUBY) extconf.rb $(RUBY_EXTCONF_ARGS); $(RUNENV) make
+ cd villa && [ -f Makefile ] || $(RUNENV) $(RUBY) extconf.rb $(RUBY_EXTCONF_ARGS); $(RUNENV) make
@printf '\n'
@printf '#================================================================\n'
@printf '# Ready to install.\n'