24289a687d
Patches for solaris and friends are reinstated (thanks jperkin@) Also thanks to he@ for testing on powerpc and arm Highlights for 4.10.0: * A new best-fit allocator for the major heap which reducing both GC cost and memory usage. * Immutable strings are now enforced at configuration time * User-defined indexing operators for multidimensional arrays * Miscellaneous improvements to the manual * A more precise exhaustiveness check for GADTs * Many bug fixes Highlights for 4.11.0: * Statmemprof: a new statistical memory profiler * A new instrumented runtime that logs runtime statistics in a standard format * A native backend for the RISC-V architecture * Improved backtraces that refer to function names * Suppport for recursive and yet unboxed types * A quoted extension syntax for ppxs. * Many quality of life improvements * Many bug fixes. 4.11.1 is a bugfix release. Full details in the CHANGELOG included with the distribution.
15 lines
430 B
Text
15 lines
430 B
Text
$NetBSD: patch-otherlibs_Makefile.otherlibs.common,v 1.3 2020/12/09 10:33:04 jaapb Exp $
|
|
|
|
Honor LDFLAGS.
|
|
|
|
--- otherlibs/Makefile.otherlibs.common.orig 2020-01-10 16:10:46.000000000 +0000
|
|
+++ otherlibs/Makefile.otherlibs.common
|
|
@@ -51,7 +51,7 @@ COBJS ?=
|
|
EXTRACFLAGS ?=
|
|
EXTRACAMLFLAGS ?=
|
|
LINKOPTS ?=
|
|
-LDOPTS ?=
|
|
+LDOPTS ?= -ldopt "$(LDFLAGS)"
|
|
HEADERS ?=
|
|
CMIFILES ?= $(CAMLOBJS:.cmo=.cmi)
|
|
CAMLOBJS_NAT ?= $(CAMLOBJS:.cmo=.cmx)
|