pkgsrc/lang/ocaml/patches/patch-yacc_Makefile
jaapb 24289a687d Updated lang/ocaml to 4.11.1.
Patches for solaris and friends are reinstated (thanks jperkin@)
Also thanks to he@ for testing on powerpc and arm

Highlights for 4.10.0:
* A new best-fit allocator for the major heap which reducing both GC cost
  and memory usage.
* Immutable strings are now enforced at configuration time
* User-defined indexing operators for multidimensional arrays
* Miscellaneous improvements to the manual
* A more precise exhaustiveness check for GADTs
* Many bug fixes

Highlights for 4.11.0:
* Statmemprof: a new statistical memory profiler
* A new instrumented runtime that logs runtime statistics in a standard
  format
* A native backend for the RISC-V architecture
* Improved backtraces that refer to function names
* Suppport for recursive and yet unboxed types
* A quoted extension syntax for ppxs.
* Many quality of life improvements
* Many bug fixes.

4.11.1 is a bugfix release. Full details in the CHANGELOG included with
the distribution.
2020-12-09 10:33:04 +00:00

15 lines
500 B
Text

$NetBSD: patch-yacc_Makefile,v 1.6 2020/12/09 10:33:04 jaapb Exp $
Honor LDFLAGS when building ocamlyacc.
--- yacc/Makefile.orig 2020-01-10 16:10:46.000000000 +0000
+++ yacc/Makefile
@@ -39,7 +39,7 @@ generated_files := ocamlyacc$(EXE) $(oca
all: ocamlyacc$(EXE)
ocamlyacc$(EXE): $(ocamlyacc_OBJECTS)
- $(MKEXE) -o $@ $^ $(EXTRALIBS)
+ $(MKEXE) $(BYTECCLIBS) $(LDFLAGS) -o $@ $^ $(EXTRALIBS)
version.h : $(ROOTDIR)/VERSION
echo "#define OCAML_VERSION \"`sed -e 1q $< | tr -d '\r'`\"" > $@