19 lines
1.1 KiB
Text
19 lines
1.1 KiB
Text
$NetBSD: patch-ak,v 1.1 2010/03/10 12:54:27 obache Exp $
|
|
|
|
pkgsrc take care permissons for directories and files.
|
|
need to user-destdir installation.
|
|
|
|
--- innreport/Makefile.in.orig 2010-03-10 12:26:40.000000000 +0000
|
|
+++ innreport/Makefile.in
|
|
@@ -265,10 +265,7 @@ uninstall-am: uninstall-info-am uninstal
|
|
|
|
# the trailing slash is to force symlink transversal
|
|
install-data-local:
|
|
- cd $(sysconfdir) && chmod 700 . && chown @nntpcacheUID@ . && chgrp @nntpcacheUID@ . && chmod 600 $(sysconf_DATA) && chown @nntpcacheUID@ $(sysconf_DATA) && chgrp @nntpcacheGID@ $(sysconf_DATA)
|
|
- -mkdir $(sysconfdir)/http $(sysconfdir)/http/innreport $(sysconfdir)/http/innreport/pics
|
|
- chown @nntpcacheUID@ $(sysconfdir)/http $(sysconfdir)/http/innreport $(sysconfdir)/http/innreport/pics
|
|
- chgrp @nntpcacheGID@ $(sysconfdir)/http $(sysconfdir)/http/innreport $(sysconfdir)/http/innreport/pics
|
|
+ -mkdir $(DESTDIR)$(sysconfdir)/http $(DESTDIR)$(sysconfdir)/http/innreport $(DESTDIR)$(sysconfdir)/http/innreport/pics
|
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
.NOEXPORT:
|