be443f0c5e
Notable changes in this latest version are listed here. Some code cleanup work and documentation editing has also been done. 256-color limit removed Icon's X-windows interface previously limited each window to 256 colors at one time. This limitation has been removed for the TrueColor displays provided by most modern computers. Median-cut quantization is used to select 256 image colors when WriteImage() is called to write a GIF file. Library changes As usual, several files in the Icon program library have been added or edited. The core library files, however, remain stable. Minor changes * The command "icon - [args]" can now be used to execute a source program read from standard input. * A new "icont -N" flag suppresses embedding of an iconx path in the generated executable * The configuration directory has been restructured. * Several obsolete configurations have been removed. * The environment variables HEAPSIZE and BLOCKSIZE no longer function as undocumented alternatives to BLKSIZE. The GNU ls utility uses BLOCKSIZE for other purposes, leading to confusion. * "make Install" has been changed to never delete anything. It now creates a new directory rather than altering an existing one.
20 lines
545 B
Text
20 lines
545 B
Text
$NetBSD: patch-av,v 1.5 2003/06/06 08:58:43 jtb Exp $
|
|
|
|
--- src/icont/Makefile.orig
|
|
+++ src/icont/Makefile
|
|
@@ -21,7 +21,6 @@
|
|
icont: $(OBJS) $(COBJS)
|
|
$(CC) $(CFLAGS) $(LDFLAGS) -o icont $(OBJS) $(COBJS)
|
|
cp icont ../../bin
|
|
- strip ../../bin/icont$(EXE)
|
|
(cd ../../bin; rm -f icon; ln -s icont icon)
|
|
|
|
$(OBJS): $(HFILES) tproto.h
|
|
@@ -66,7 +65,6 @@
|
|
ixhdr.hdr: ixhdr.c ../h/define.h ../h/config.h ../h/header.h $(COBJS)
|
|
$(CC) $(CFLAGS) $(LDFLAGS) -o ixhdr.hdr \
|
|
ixhdr.c ../common/alloc.o ../common/munix.o
|
|
- strip ixhdr.hdr
|
|
|
|
|
|
|