d8b0ac6d1a
The makefiles for this should really be rewritten to use libtool; using two makefiles for two different platforms isn't the way we tend to do things around here ... ;) Blurb: Rtunes streams files containing Apple Lossless audio data to an Apple AirPort Express device. If a '-' is given as the file(s) argument, rtunes expects raw PCM audio data on stdin and encodes it to the Apple Lossless format prior to streaming it. With this method it is possible to stream audio data from any source that can output raw PCM audio data on stdout. NOTE: the patch and mplayer helper library for this package are untested; it is installed merely as a convenience.
53 lines
2.2 KiB
Text
53 lines
2.2 KiB
Text
$NetBSD: patch-ae,v 1.1.1.1 2007/11/23 00:18:41 bjs Exp $
|
|
|
|
--- librtunes/mplayer.diff.orig 2007-02-07 14:49:34.000000000 -0500
|
|
+++ librtunes/mplayer.diff
|
|
@@ -1,6 +1,6 @@
|
|
-diff -urN MPlayer-1.0pre8/Makefile MPlayer-1.0pre8-rtunes/Makefile
|
|
---- MPlayer-1.0pre8/Makefile Sun Jun 11 20:35:47 2006
|
|
-+++ MPlayer-1.0pre8-rtunes/Makefile Wed Feb 7 20:26:10 2007
|
|
+diff -urN Makefile Makefile.orig
|
|
+--- Makefile.orig Sun Jun 11 20:35:47 2006
|
|
++++ Makefile Wed Feb 7 20:26:10 2007
|
|
@@ -105,6 +105,8 @@
|
|
$(X264_LIB) \
|
|
$(MUSEPACK_LIB) \
|
|
@@ -18,9 +18,9 @@ diff -urN MPlayer-1.0pre8/Makefile MPlay
|
|
libmpcodecs \
|
|
libavutil \
|
|
libavcodec \
|
|
-diff -urN MPlayer-1.0pre8/libao2/Makefile MPlayer-1.0pre8-rtunes/libao2/Makefile
|
|
---- MPlayer-1.0pre8/libao2/Makefile Sun Jun 11 20:35:42 2006
|
|
-+++ MPlayer-1.0pre8-rtunes/libao2/Makefile Wed Feb 7 19:42:13 2007
|
|
+diff -urN libao2/Makefile libao2/Makefile.orig
|
|
+--- libao2/Makefile.orig Sun Jun 11 20:35:42 2006
|
|
++++ libao2/Makefile Wed Feb 7 19:42:13 2007
|
|
@@ -6,6 +6,7 @@
|
|
ao_mpegpes.c \
|
|
ao_null.c \
|
|
@@ -29,9 +29,9 @@ diff -urN MPlayer-1.0pre8/libao2/Makefil
|
|
$(OPTIONAL_SRCS) \
|
|
|
|
OBJS=$(SRCS:.c=.o)
|
|
-diff -urN MPlayer-1.0pre8/libao2/ao_rtunes.c MPlayer-1.0pre8-rtunes/libao2/ao_rtunes.c
|
|
---- MPlayer-1.0pre8/libao2/ao_rtunes.c Thu Jan 1 01:00:00 1970
|
|
-+++ MPlayer-1.0pre8-rtunes/libao2/ao_rtunes.c Wed Feb 7 19:45:43 2007
|
|
+diff -urN libao2/ao_rtunes.c libao2/ao_rtunes.c.orig
|
|
+--- libao2/ao_rtunes.c.orig Thu Jan 1 01:00:00 1970
|
|
++++ libao2/ao_rtunes.c Wed Feb 7 19:45:43 2007
|
|
@@ -0,0 +1,142 @@
|
|
+#include "config.h"
|
|
+
|
|
@@ -175,9 +175,9 @@ diff -urN MPlayer-1.0pre8/libao2/ao_rtun
|
|
+{
|
|
+ return (0.0);
|
|
+}
|
|
-diff -urN MPlayer-1.0pre8/libao2/audio_out.c MPlayer-1.0pre8-rtunes/libao2/audio_out.c
|
|
---- MPlayer-1.0pre8/libao2/audio_out.c Sun Jun 11 20:35:42 2006
|
|
-+++ MPlayer-1.0pre8-rtunes/libao2/audio_out.c Wed Feb 7 19:47:07 2007
|
|
+diff -urN libao2/audio_out.c libao2/audio_out.c.orig
|
|
+--- libao2/audio_out.c.orig Sun Jun 11 20:35:42 2006
|
|
++++ libao2/audio_out.c Wed Feb 7 19:47:07 2007
|
|
@@ -68,6 +68,7 @@
|
|
extern ao_functions_t audio_out_mpegpes;
|
|
extern ao_functions_t audio_out_pcm;
|