changes: added dialog for tab-focus order, file generation separate for sources and .dlg file avoid the X11R6/libXft trap update some C++ for gcc-3.3 This should fix the build errors seen in bulk builds
15 lines
522 B
Text
15 lines
522 B
Text
$NetBSD: patch-ab,v 1.3 2004/09/10 15:43:51 drochner Exp $
|
|
|
|
--- bmp/Makefile.orig Fri Apr 28 02:41:56 2000
|
|
+++ bmp/Makefile
|
|
@@ -95,7 +95,9 @@
|
|
include ../Makefile.common
|
|
|
|
qembed: qembed.o
|
|
- $(CC) qembed.o -o qembed -Wall -L$(QTDIR)/lib -lqt
|
|
+ $(CC) ${LDFLAGS} qembed.o -o qembed -Wall -L$(QTDIR)/lib -Wl,-R$(QTDIR)/lib -lqt \
|
|
+ -L$(X11BASE)/lib -Wl,-R$(X11BASE)/lib -lX11 -lXext -lSM \
|
|
+ -L$(LOCALBASE)/lib -Wl,-R$(LOCALBASE)/lib -lpng -lz
|
|
|
|
$(BMPSOURCE): $(BMPS) qembed
|
|
./qembed $(BMPHEADER) $(BMPSOURCE) $(BMPS)
|