21 lines
918 B
Text
21 lines
918 B
Text
$NetBSD: patch-aj,v 1.3 2010/05/04 18:55:46 jym Exp $
|
|
|
|
--- libxutil/Makefile.orig 2005-05-24 00:36:28.000000000 +0000
|
|
+++ libxutil/Makefile 2005-05-24 00:38:14.000000000 +0000
|
|
@@ -65,11 +65,11 @@
|
|
fi
|
|
|
|
install: build
|
|
- [ -d $(DESTDIR)/usr/lib ] || $(INSTALL_DIR) -p $(DESTDIR)/usr/lib
|
|
- $(INSTALL_PROG) libxutil.so.$(MAJOR).$(MINOR) $(DESTDIR)/usr/lib
|
|
- $(INSTALL_DATA) libxutil.a $(DESTDIR)/usr/lib
|
|
- ln -sf libxutil.so.$(MAJOR).$(MINOR) $(DESTDIR)/usr/lib/libxutil.so.$(MAJOR)
|
|
- ln -sf libxutil.so.$(MAJOR) $(DESTDIR)/usr/lib/libxutil.so
|
|
+ $(BSD_INSTALL_LIB_DIR) $(DESTDIR)$(PREFIX)/lib
|
|
+ $(BSD_INSTALL_LIB) libxutil.so.$(MAJOR).$(MINOR) $(DESTDIR)$(PREFIX)/lib
|
|
+ $(BSD_INSTALL_LIB) libxutil.a $(DESTDIR)$(PREFIX)/lib
|
|
+ ln -sf libxutil.so.$(MAJOR).$(MINOR) $(DESTDIR)$(PREFIX)/lib/libxutil.so.$(MAJOR)
|
|
+ ln -sf libxutil.so.$(MAJOR) $(DESTDIR)$(PREFIX)/lib/libxutil.so
|
|
|
|
clean:
|
|
$(RM) *.a *.so* *.o *.opic *.rpm
|